Rebase to Copter 4.1, got waf build error

Hi everyone,

i rebase to Copter-4.1, before is Copter 4.07. Now there is an error when waf build.

ubuntu@ubuntu:~/workspace/ardupilot$ ./waf copter
Waf: Entering directory `/home/ubuntu/workspace/ardupilot/build/fmuv5’
Checking for
env added HAL_NUM_CAN_IFACES=2
env added BOARD_FLASH_SIZE=2048
env added PROCESS_STACK=0x1C00
env added APJ_BOARD_TYPE=STM32F767xx
env added OPTIMIZE=-O2
env added USBID=0x1209/0x5740
env added MAIN_STACK=0x600
env added APJ_BOARD_ID=50
env added CORTEX=cortex-m7
env added FLASH_TOTAL=2064384
env added CHIBIOS_BUILD_FLAGS=USE_FATFS=yes MCU=cortex-m7 ENV_UDEFS=-DCHPRINTF_USE_FLOAT=1 CHIBIOS_PLATFORM_MK=os/hal/ports/STM32/STM32F7xx/ CHIBIOS_STARTUP_MK=os/common/startup/ARMCMx/compilers/GCC/mk/
env added IOMCU_FW=0
env appended CPU_FLAGS=[’-mcpu=cortex-m7’, ‘-mfpu=fpv5-d16’, ‘-mfloat-abi=hard’, ‘-DARM_MATH_CM7’, ‘-u_printf_float’]
env added PERIPH_FW=0
env added WITH_FATFS=1
Padded 8 bytes for bootloader.bin to 16448
Embedding file bootloader.bin:/home/ubuntu/workspace/ardupilot/Tools/bootloaders/fmuv5_bl.bin
Embedding file io_firmware.bin:Tools/IO_Firmware/iofirmware_lowpolh.bin
[ 4/10] Creating build/fmuv5/hwdef.h
[ 8/10] Creating build/fmuv5/ap_version.h
Adding environment OPTIMIZE -O2
Setup for MCU STM32F767xx
Writing hwdef setup in /home/ubuntu/workspace/ardupilot/build/fmuv5/hwdef.h
MCU Flags: cortex-m7 [’-mcpu=cortex-m7’, ‘-mfpu=fpv5-d16’, ‘-mfloat-abi=hard’]
Writing DMA map
Generating ldscript.ld
No default parameter file found

Waf: Leaving directory `/home/ubuntu/workspace/ardupilot/build/fmuv5’
Build failed
-> missing file: ‘/home/ubuntu/workspace/ardupilot/build/fmuv5/hw.dat’

Any idea will help , thanks.

did you do a “./waf clean” and a “./waf distclean” ?

1 Like

thank for reply, i did waf clean and waf distclean, and absolutely the error just the same.

after the rebase is finished, i run this cmd:
git submodule update --recursive

./waf configure --board fmuv5

./waf copter

and then the error just show.

Some other ideas:

  • remove the “build” directory…
  • git submodule update --init --recursive

did you try “rm -rf build” (or the Windows equivalent)?

1 Like