RCx_reversed does not work (copter 4.0.3)

I am having issues with pitch control being reversed on a cube/4.0.3 multi rotor build.

If I use “RCx_reversed” and change the value to 1 the channel does NOT reverse. This seems to be the case for all input channels. 1 thru 4

I can reverse the channels in my TX but the preferred solution is for RCx_reversed to work!

Can anyone else verify that this is an issue?

Did you tried it in flight or just checked in Mission Planner ?

Checked in mission planner on the RC calibration screen.


I don’t think it works and I don’t think it has ever worked actually. Happy to be proven wrong and we could add an enhancement to the issues list to make it work. I think in Copter we did not implement it because we did not have separate parameters for input vs output channels until Copter-3.5.

I’ve set the pitch channel reversal in the taranis for all models, and also the default AETR channel options so that all our Ardupilots are using there default settings for RCMAP and pitch always works as expected (by Ardupilot)

1 Like

@rmackay9 @xfacta
That is interesting to hear. I will do some more experimentation to verify the behavior and then raise an enhancement request.

I have built approx 15 arducopter based platforms in the last year, all using frsky Taranis and it does appear that sometimes the default setup leaves pitch inverted meaning I have to reverse in the TX if rcx_reversed doesn’t work.
Unsure why each build is not the same and only some of them require reversal.
It’s worrying because as our craft get ever bigger the consequences of the controls being reversed are quite high.

I do tend to come up light on the skids and check control inputs before lifting but this has its own risks.

Be curious to hear what other people’s experiences of this is?


I allow myself to intervene on this post because I have a similar request for the RC reversed.

I use a Herelink transmitter on which you cannot reverse the RC.

I want to use the “Motor Interlock” command. With this command, in low RC, the motors are stopped and in high RC, the motors run.

My problem is when my multirotor is in flight, if the radio control restarts, the motors will stop when connecting with the device.

If you cannot use RC reversed, is there a way to modify the behavior of the “Motor interlock” command ?

i bought 3 servos - the same model - from one manufacturer. 2 are turning one way and one the other.
i installed them on 3 different models that are controlled via the same single model definition on the radion. the servo is used to rotate fpv camera.
Changing the direction on the transmitter is not an option as i need the same radio profile to control all 3 models.
I thought that either by changing rc6_reverse or servo6_reverse from 0 to 1 i could change the direction but no luck. neither of these options take any effect - this behaviour was observed in ardu plane but i believe ardu copter is the same.

btw. its also the case with servoX trims options - no effect

So I guess the vehicle is configured so that some of the RC inputs are passed through to the outputs? I’m afraid we don’t have an option to reverse or apply scaling as part of passthrough. It’s just a simple passthrough. It might help to setup it up as a gimbal (aka mount)

1 Like