RCMAP Parameters and Spektrum AR8000

I have a Spektrum AR8000 with a 3DR PPM encoder. Normally, I have to input the PPM encoder leads to the AR8000 in Mode 1 order (throttle is channel 3), but I would like to be able to input them in Mode 2 order (throttle is channel 1). I thought I could do this by changing the RCMAP parameters to assign throttle to channel 1, etc., but changing the parameters doesn’t seem to work. It works correctly immediately after writing the parameters; however, after a power cycle, everything reverts back to being incorrect, even though the parameters appear to be “saved”. Does anyone have a solution for this problem?


Mode 2 is actually throttle on channel 3.

If you want to change modes you can do it in one of 3 manners;
There is the internal wiring on the spektrum as shown here:

Then there’s the RC mapping, if you’re doing this in full parameter list, remember to hit write params to save these settings.

On some RC transmitters you cna also set these changes on the controllers menus although I’m not too sure if spektrum has this option.

Ah, my mistake. I got my modes mixed up. I’ll try your suggestions and see if I can get everything to work. Thanks!

So, I think I may need to clarify want I want to achieve, and perhaps I can get some more insight/instruction. I want my transmitter to have throttle on channel 1, which currently, it is. However, the Pixhawk is expecting throttle to be on channel 3. I’ve tried changing the RCMAP parameters in the Full Parameter List and writing the new parameters to the Pixhawk. This works temporarily, but as soon as I power cycle the Pixhawk, it reverts back to receiving the inputs on different channels. I’m curious why the parameters don’t seem to save permanently. I hope this makes sense. Thanks!

I get you now… sometimes the pixhawk doesn’t retain values due to some sort of bug under very specific conditions (not really sure what yet) and there’s a quick fix which has worked in the past. You’re gonna need to flash plane or rover firmware and then back to copter firmware… give this a shot as it worked a while back on a very similar issue where some setting were reverted back after a power cycle.

I’ve flashed ArduPlane and then re-flashed ArduCopter and I’m still encountering the same problem. If there isn’t a known solution to this issue, I’ll just manually rearrange the PPM Encoder leads as a fix. Thanks for your help, though!

I have the same problem (PPM with Graupner MX12 with FrSky DHT-U 2.4GHz module and FrSky D8R-XP receiver). But I guess that the real problem is in the RCMAP_ Parameters’s page because when you tune the channel, save it, go to another page and go back to the RCMAP_ Parameters, values are changed! Moreover, channel can be tune until 1 and 8. But when you move the cursor on the slide bar, you can leave the cursor on a value that between (for example) 2 and 3 :open_mouth:. Other strange things, the button to increase or decrease value have a strange behavior (like 3 jump to 1 when you decrease). It’s like value is hold by a real number against an integer and strange operation occur when you increase or decrease.
The more strange problem is that “RCInput_MPNG.cpp” not resolve my problem when I use Graupner mapping.

I spent a long night time yesterday to try make working that. This evening I will check PPM_PL1 (I have a CRIUS AIOP V2) and old PWM to see if the problem could be solved like that… :confused:

1 Like