Servers by jDrones

Raspberry pi won't run mavlink on boot

I am trying to get a headless Raspberry Pi to run Mavlink. I have set up Mavlink and have everything running well when I ssh or directly connect to the pi and type the commands. My Mavlink setup is also running Dronekit and a custom script to take GPS coded images from the pi’s camera.

if I run:

everything runs, connects, and the script starts properly. However if I add this suggested code to the rc.local:

( date echo $PATH PATH=$PATH:/bin:/sbin:/usr/bin:/usr/local/bin export PATH cd /home/pi screen -d -m -s /bin/bash mavproxy.py --master=/dev/ttyAMA0 --baudrate 57600 --aircraft MyCopter ) > /tmp/rc.log 2>&1 exit 0
the script does not run and I there is no “screen” to switch to once I log in to debug (as indicated there should be here http://dev.ardupilot.com/wiki/companion-computers/raspberry-pi-via-mavlink/.)

I have tried adding the path to the mavinit.scr and my custom script in the “PATH” command as well to no avail. Has anyone else gotten a headless Pi to work with mavlink?

Hi nweydert,
I have found your post because I have exactly the same problem. Did you find any solution?
Thanks.

Having the same problem. Raspberry pi just hangs after booting and can’t enter any commands.

Servers by jDrones