Servers by jDrones

Raspberry Pi and Pixhawk Connection

So, my main goal is to connect raspberry pi to the pixhawk which is connected to a sabre-tooth motor controller on my rover, and then use the Pi to run the motor.

I have been facing a frustrating issue:

  1. When I connect the Pi to my Pixhawk (the pixhawk is connected to the laptop using USB and Q Ground Control is used on the laptop), connection is established, I am able to change modes on q ground control using my pi, arm throttle using my pi and change parameter values using my pi as well.

  2. Now, since the rover has to move and the laptop cannot move with it, we used telemetry 1 to establish a wireless connection and use a portable battery for a pixhawk.

The issue is, the connection between the Pi and the PixHawk only happens when we use USB with our laptop. While doing (2), the connection fails and theres BAD_DATA shown on the Pixhawk Console.
How can this be fixed? Also, we aren’t being able to move the motors at all.
How to do so?

Double check that SERIAL1_PROTOCOL = 2 (MAVLink 2) and SERIAL1_BAUD is the same baud rate that you’re using on your wireless connection.

What hardware are you using to create the wireless connection?

Servers by jDrones