Raspberry Pi 3b+ Dronekit-sitl

I am looking for some clarification on the use of Dronekit and Dronekit-sitl.

I am attempting to connect a Raspberry Pi 3b+ to a Pixhawk Cube Black. I am currently using mavlink to communicate between the Raspberry Pi and the Cube. To set this up and used the tutorial here https://ardupilot.org/dev/docs/raspberry-pi-via-mavlink.html.

When I tried to continue in this tutorial I installed dronekit and dronekit-sitl using the tutorial here https://dronekit-python.readthedocs.io/en/latest/guide/quick_start.html. I did this on the Raspberry Pi. When I made the python script writen in the tutorial and ran it I got this message:

How do I go about fixing this?

Some sources have said to erase both python3 and python and reinstall python but when I do this the GUI for the Pi goes away and the same error happens.

Do I need to install sitl on my laptop as well? Thanks for any help you can provide.

Hi Noah,
I receive the same messages on a similar project.
After some searches, I found the problem is related to the dronekit-sitl: it doesn’t run on ARM architecture like the RPi.

Hey Matteo,
Does this mean i need to abandon the Pi or is there a work around? I am open to using a different onboard computer.

I also do not need dronekit-sitl to run just dronekit if my understanding is correct. I have the Pi connected to the telemetry port on the Pixhawk cube black. If I just get dronekit working I can send commands directly to the Cube so I do not need the simulator. However I am getting a similar error when I try to load dronekit where the Pi says it the dronekit package is not found.

Hi Noah,
you can use the RPi directly connected to the Pixhawk in order to provide commands to your drone.
As work around for the simulation of a drone, you can install dronekit-stil on another certified platform.