Radiolink telemetry radio on ArduCopter 4.1 08102021 latest, Pixhawk 2.4.8 (Pixhawk1) breaks connection

This is on a Radiolink Pixhawk from Amazon. Telemetry radio on Pixhawk 4.1 08102021 latest Pixhawk1 and fmuv3 breaks telemetry connection, and makes it very slow.

The same hardware configuration works on Pixhawk-1M with a Pixhawk 2.4.8, but I needed PRX, obstacle avoidance and terrain following enabled so I switched.

The hardware is the fpvdrone 915/433 sik telemetry radio 100mW. Along with a Frysky x4r on sbus, and a rpi4b on USB. Lastly serial4 has a minitf lidar Rangefinder using the option 8 lightware serial driver.

The missionplanner always hangs receiving waypoints, and gives an error. Then the sink radio slows down to a trickle update for parameter downloading, and starts giving messages like MAV not found, and everything goes really slow motion and doesn’t really work.

Please help this seems to be an issue on fmuV3 and Pixhawk1, honestly I seen this before on earlier versions of ArduPilot. So I’m hoping somebody has a workaround or a suggestion I appreciate it thank you.

This is a bit more urgent than usual because I’ve been trying to test this in the desert for a month now after an initial crash, and I just want to go home so if anybody can provide a solution I will be grateful.


Anything Radiolink is a mistake. Pixhawk1-1M is not correct for a Pixhawk 2.4.8. Those have 2mb flash so Pixhawk1 is the correct firmware.

I took your advice and reinstalled the pixhawk 2.4.8, and I get the following message. Prearm board 4.1v out of range What’s going on now? Should I of reinstalled the 2.4.8 Pixhawk?

That’s a problem with the power brick if you are running it off battery - if you are only running it off USB for config/testing then that could probably be ignored.

It went away when I plugged in battery. Initially it was loading a couple way points and giving the unexpected error but it’s completely doing the same thing as the radio link was now. With the Unexpected error.

It seems a little smoother and less bogged down to but it’s still stuck. Unplugging the USB to the companion computer doesn’t affect the issue I’m just throwing that in the information.

1 Like

Do you have scripting enabled and you use it?
I had to use a later FC to use scripting. MavFTP and maybe some other things didnt work properly with scripting enabled on a Pixhawk1

Scripting shouldn’t be enabled unless it defaults to on. I didnt turn it on.

I also don’t use Mavftp but missionplanner goes through a routine to load that stuff anyways, which isn’t always helpful when it breaks ArduPilot.

MAVFTP is used to speed up parameter download, and you need it on 4.1

Power issue perhaps? Those 2.4.8’s had some power components removed that is a downgrade from the previous models.

Maybe try disconnecting the lidar and rp4 just to see if that helps

1 Like

The same thing happens on both 2.4.8, and Radiolink Pixhawk hardware using Pixhawk1. Pixhawk-1M doesn’t have the issue with the same exact hardware configuration. It seems like a bug in the firmware to me. I think we could probably even deduce it’s in the integration of components, and since it gets real slow and seems somewhat variable maybe it’s some sort of nested loop getting stuck but possibly timing out after a period of time. It might even be getting triggered by a missionplanner connection routine and the order of that routine? Missionplanner does almost lock up when it gets into this race condition sometimes freezing the GUI till it times out

Scripting is disabled. Please accept my sincere apology I was wrong, when I completely remove power and then unplug the miniusb cable the telemetry radio works. I don’t receive an error on connect in missionplanner. The failure on downloading waypoints only occurs when the usb is plugged in. I disabled mavros and the d435 obstacle avoidance scripts and it made zero difference. The only factor that seemed to matter was whether or not the USB cable was plugged in at startup. I just thought of another test I can try. Do you have the mavlink router configured and I didn’t disable that I will try that real quick and if I don’t update here it means mavlink-router disabled made no difference as well.

Problem deduced to cannot connect with sik telemetry if USB cable is plugged into companion computer with Pixhawk 2.4.8, I’ll assume the exact same behaviour occured on the Radiolink Pixhawk, since the exact same thing happened running Pixhawk1. The issue did not occur on Pixhawk1-1M with the same hardware connected. Is there a setting of some sort? Or is this a bug.

It’s strange the issue occurs even if nothing is running on the companion computer that connects via the serial port therefore it seems that this has to do with only the serial Port being physically plugged in. The Raspberry Pi is running off a different voltage regulator using the motor power sources and therefore should not be draining any voltage. It runs standalone.

I’ll try disconnecting the lidar next to see if that makes a difference.

Lidar being unplugged from serial 4 made no difference. This is literally a problem that if the USB port is plugged in the sik telemetry radio throws unexpected error attempting to download waypoints in missionplanner. It us connecting to raspberry pi 4b companion.

Ok, this last test worked. When I disconnected the companion computer and plugged the USB directly into my laptop and then connected via the USB sick Telemetry radio it did connect with no problems. What does this mean? I disconnected raspberry pi directly from battery and ran it from 5 amp ac power source, and still I get the unexpected error from Pixhawk at startup. This leaves me perplexed because it doesnt appear to be a raspberry pi Pixhawk power issue, and the pixhawk was receiving full power from the power module.

What about disconnecting the power wire from in the USB cable? You will just need the data and ground wires obviously.

Here’s the thing, it worked fine when the usb was connected to the laptop groundstation. And I connected via the sik radio. The issue only occurs from the raspberry pi. Do you think my destroying my USB wire is going to fix it? The USB on my laptop literally was powering the Pixhawk before I turn the battery power on. If you legitimately think it will fix the problem I will cut the power wire. Don’t want to do it unless it will fix it. Also, I know everything works fine when I use the Pixhaek1-1m firmware except it’s missing functionality I need. If the power wasn’t an issue on pixhawk1-1m why would it be an issue on the Pixhawk1 firmware?

Good points - I don’t know the answer, I cant test it here myself unfortunately.

I want somebody who knows the code to look at this issue with the USB. The docs themselves say don’t use the USB for a companion computer, because things like battery monitor won’t work right, and to only use it when connecting directly to gcs. I’m going to speculate this is a bug, because the thing works on Pixhawk1-1m, and if it’s not a bug it’s because somebody has hard coded it not to work and in my case the USB is the only Port that makes sense to do this on my build. I just want to do test flights so any assistance you are able to provide in resolving this issue will be appreciated. Maybe a dev on the firmware can look at the code as it pertains to serial0, or USB on Pixhawk1?



Connecting to companion computer does work fine, but it is not advisable for all the reasons stated in the docs.

So in other words:
You can do it, as long as you take the responsibility for that decision and do not complain to the developers (that warned you about it) if the drone crashes.

1 Like