Radio setup ( holybro f7, tbc crossfire , tango 2 )

Hello , since this is my firs post I would like to say hi to all of you :slight_smile:

Im trying to switch from betaflight to arducopter ( but is not so easy :slight_smile: )
I have a problem with very basic thing - radio setup.
I have a multirotor on holybro f7 aio 1.5 with TBS crossfire nano at uart 6, . ( like on the link below in wiring scheme ) and radio TBS crossfire tango 2
And I flashed FC with latest stable arducopter_with_bl.hex
It was working well on BF but here I have problems and I’m not able to connect to radio.


what I’m doing wrong ? and what else I need to set ?

Sorry maybe for stupid question but I’m starting my learning curve with ardupilot. And I will improve :slight_smile:


Not supported on 4.0 - you need to load the beta 4.1 firmware

If you are coming from BetaFlight I highly recommend you use 4.1 - the differences between 4.0 and 4.1 for people who are used to BF are significant

1 Like

Try running S BUS on channel one of your receiver.

I’ve check 4.1 and it actually works. Not sure why, since I didn’t set uart 6 to be my receiver but radio is working.


So I’ve had one win today with my F7 mini and instead of thinking it’s a hardware problem I’m going to confirm it’s not my parameters.

Kakute F7 AIO V1.5
F35 BLHeli32 ESC’s
CRSF 4.11
Arducopter 4.1 with BLHeli

I had to turn off BRD_ALT_CONFIG and I also set SERIAL6_PROTOCOL = 29 and my Tx is talking to my Rx. If I set to 1 and 23 respectively it doesn’t work. I’m only picking up 14 sensors. I should have around 23? The sensors I do have are all Rx telemetry.

Apex Ardu.param (16.9 KB)

Any fault finding would be appreciated.

Protocol 29 is only for VTX control via CRSF without RX. You must use protocol 23 if you want RX control.

1 Like

Thanks Andy, I’m clearly tired and making mistakes.
I won’t have 23 sensors either as I don’t have my peripherals connected yet.

Everything works. Just need the lock down to pass to start tuning.

Your patience is appreciated.

1 Like