Radio Failsafe Late Frame and Scary Loiter

Good morning all.
I took one of my large drones out for a spin today. It’s the first flight since an overhaul. Had some frame issues i wanted to resolve. Anyway it took off just fine but then gave me two problems.
A really scary loiter. Now I confess this bird needs a tune… But I have been fighting other issues so the tune hasn’t really happened and the second thing is a radio failsafe…due to a late frame. It cleared and the machine had no issue. I landed safe but I have never encountered that before.
What was even stranger was just before it happened I see the strobes start flashing. These strobes are controlled by RC14 and where not commanded to come on. Shortly after I see it blink I get a radio failsafe. So I imagine there was a receiver issue that may have tripped the pwm value that makes the strobes go. But I don’t see it in the log.

Anyway if anyone can have a look at the logs I would appreciate it. I need to have a better loiter then this and radio failsafe…not good.
Also what’s Motor Interlock I see that message all the time.
ArduCopter V4.0.6 (13b6478d)

What version are you flying?

Sorry Andy I should have mentioned that
ArduCopter V4.0.6 (13b6478d)

FWIW I know people have had issues with SBUS if their RX is not on a DMA UART - but it really depends on your setup

It’s plugged into the SBUS in for the pixracer.

I would expect that to be ok

So what is a late frame. I get the impression is a failure of the receiver to give a piece of data in a timely fashion to the flight controller.

Anyone know what the effect would be on the receiver it the antenna was up against a metal frame part of even grounded out against it. Would that cause a late frame

I noticed there is some exposed metal here. I have since recovered the whole pigtail.


I had the same late frame error (first occurence) the other day just after landing.

I cannot explain why. It was a flight with a new transmitter (Futaba T16iz) and antenna was in the “store” position. RX was a R6303SB.

I discovered the “failsafe” message at home when looking the log.

I changed the RX for one with telemetry, had another flight with 4.0.6 and since changed to 4.0.7 without other “failsafe” event

Hi @rickyg32

The RADIO_LATE_FRAME error means there is no data coming from port to which receiver is connected. The error raises after 500ms from the last received data.
There may be different reasons I believe: physical wire problem, receiver hardware/firmware problem or some FC hardware/firmware problem.

I tried to check your log, but I didn’t found a right one. There are two .bin files. One has late frame error, but no Loiter mode. Another one is vice versa.

1 Like

Hi @mlebret I will do the 4.0.7 upgrade in the next day or so and see if that helps. Thank you for your feedback. the receiver I have on board is a telemetry receiver and it also has redundant power.

@sergbokh yes I read up on the error but it wasn’t to much help. I also suspect a physical issue with the receiver as it has worked flawlessly on this machine for sometime. I discovered in my subsequent investigation that the insultation on one of the pigtails had been scrapped up and exposing the metal side of the balun. Where the antenna comes out of the canopy is beside a metal frame and I suppose it’s possible the exposed metal touched the frame momentarily.
This is all I can find so far.

Whats odd is the logs show no receiver issues other then the error. Just the failsafe.
So I replaced the insultation and mounted the antenna to prevent any future movement.

Can I ask…is Radio Late frame another way of saying radio failure…just more technical sounding.
I ask because I went to the field again today and had another radio failsafe. This time I noticed that my transmitter was telling me teh connection was intermittent.

So I was …well ticked off at having this problem and so packed up and hit the bench.
I was about to take the receiver and replace it when I noticed something odd.

Not sure what it is but I don’t think this is right lol

The RC protocol implementations all understand how frequent frames should be for the protocol and will measure this time. If a frame does not appear in that time you will get this error and a failsafe. Causes can be external - hardware problems/ radio problems - and internal - DMA issues, load on the flight controller.

so I wonder. if a receiver is working but the antenna disconnects, would it still present the frame in the right time or would it stop and be late.

I wish I understood this stuff better.
Well I have reattached everything and will get back to the field again.


I don’t know if I can rely on this post but I think it complements the original question by relating my experience at the time.

For about a month now we have been experiencing on several machines that were working normally before, strange behaviors that could lead to a crash, with the following message when analyzing the logs : Radio Late Frame.

The Arducopter firmware is still the same: 3.6.12 but this type of error seems to happen since the last HereLink updates, without however having found a tangible proof.

Far from me to blame anything without proof and I take the liberty to ask the question here to have an informed opinion by the community of users and developers.

Have you also had this type of problem recently ?

Of course, there were no other signs of malfunction such as no video signal on the Herelink.

I will finish by pointing out that I also asked the question on the CubePilot forum

Thanks a lot,