Servers by jDrones

Quadplane RTL error


(darrell) #1

I’ve been out testing a new build of a Skywalker X8 quadplane and it’s been flying great! Yesterday I was testing battery low voltage tripping a failsafe set to RTL. The plane flew back towards me but didn’t stop at the home point and continuing on past me. I’ve never had this happen before so I was a bit stunned. I probably should have switched modes to FBWA but instead I guided it back just using the sticks. If I let go of them it tried to take off again but I managed to get it close enough to do a manual landing. I think that I switched it to QRTL manually or Stabilize but I managed to land it.

I was flying an auto mission at the time and throughout the flight I received a few GPS errors. The plane was flying fine and hit all the waypoints so I let it continue on. I’m wondering if this what caused the issue with the RTL? If anyone has time to look at the logs I’d appreciate some feedback. RTL has always worked rock solid for me and extremely accurately so I was caught off guard by this.

Log is Log for Skywalker poor RTL


(peterbarker) #2

Looks like the vehicle was correctly navigating home:

(the line colour represents your input on channel 1)

Then the question becomes - why is home in the middle of nowhere?

You might check your telemetry log to see if the GCS specified this location.


(darrell) #3

I just replayed the tlog in Mission Planner and it’s full of errors. The plane had been sitting in the sun for about 30 mins before take off. I noticed the baro says -12M before takeoff and during landing it said -30M. Lots of bad GPS errors, a compass variance error. No idea how the home point was set so far behind me. I did do a ‘set home point here’ command at some point during the day. I have fat fingers but I don’t think I could miss by that much. By comparison, the flight earlier on in the day was absolutely perfect.