Servers by jDrones

QuadPlane Pitches Up using v3.8.0 beta 5

(tridge) #87

@GregCovey have you tried setting up this quadplane as an H frame? You’re clearly getting a lot of wing twist, and the frame is laid out as an H, not an X, but it is configured as an X. The difference between X and H is the direction of the twist the motors impart to the frame.
I think you should try Q_FRAME_TYPE=3 and reversing the vertical motors (thus making it a H frame).

(Greg Covey) #88

Hi Tridge,

Thanks for visiting! I like your suggestion and will give it a try. Also, nice catch on the THR_MAX default setting. If I had one last question to ask, it would be what you thought the best setting is for Q_MOT_SPIN_ARMED on a QuadPlane?


(Iam) #89

I just use the minimum setting that keeps the motors spinning without and hiccups.

(tridge) #90

that depends on the individual hardware. You want it to be a level that causes the motors to reliably spin, but not so fast that it would hurt someone if their hand got in the way. I usually adjust it up and down until I’m happy with it based on that criteria.

(Greg Covey) #91

Ok, thanks guys, I’ll change my setting from 0 to a slow spin when armed.

When I built this QuadPlane, I used the HK 3.5mm bullet connectors so it was an easy change from X-frame to H-frame buy swapping one of the connectors 180 degrees to swap the two outer wires. The props were then changed front-to-back and back-to-front. I then changed the Q_FRAME_TYPE from 1 to 3.

I didn’t have much time to test yesterday but in QSTABILIZE I could bring the tail up and move the plane properly forward, backward, left, and right with the transmitter stick. As soon as I lifted the gear mains off the ground, the plane would spin clockwise (when viewed from above) about 90 degrees per second. I’m not sure if I need to change PIDs or reverse the rudder control on APM.

(tridge) #92

That usually means Q_FRAME_TYPE is wrong. It is exactly the effect you get when you try to fly X as H or H as X
Double check your settings, and try using motortest to check the direction of each motor

(Greg Covey) #93


Thanks for the suggestions. I’ll give it another look soon…

(Greg Covey) #94

I found the issue was that my front right boom had broken again after landing in the tall bushes. It was originally broken on my first crash a few videos ago. The Q_FRAME_TYPE is 3 (still v3.6.0) and motor test worked perfectly using 7% throttle. The Ranger EX hovers perfectly as an H-frame in my backyard.

(Alexander Perez) #95

That’s awesome Greg. Any videos yet on forward flight attempts?

(Greg Covey) #96

I may get to test it on Sunday as the weather seems reasonable. I won’t go back to the tall bush area as the rain this summer has created monster weeds!

(Alexander Perez) #97

Awesome! Good luck this round. I’m confident you’ll have a successful flight this round.

(arruntus) #98

Congratulations :grinning:

Sometimes the dumbest thing in front of our eyes drives us crazy.

This is where experience and good work are noted.

Now version 3.8.0 is just coming out of the oven :stuck_out_tongue_winking_eye:

(Greg Covey) #99

Today the larger fields were busy so I could only test QSTABILZE mode at a smaller school field. The hover testing worked fine with my new H-frame setup but there was an issue with MANUAL mode. The video shows two of the quad rotors turning in MANUAL mode that also increased with throttle.

Since I won’t be able to test again until Labor Day Weekend (2 weeks), my plan is to upgrade from v3.6.0 to the newly released v3.8.0 by first loading Rover firmware so I get a clean parameter list. I will then manually enter my critical parameters from v3.6.0 by hand using Mission Planner and post the file here for review. I will also re-test MANUAL mode to see if the quad rotor issue was resolved. Comments welcome…

(arruntus) #100

Hi Greg

Just a note about resetting the parameters. I previously always reset the parameters as you commented but… One day configuring the mutirotor, I loaded the arduplane version to later put the arducopter version again and… disaster… First, never set up with the propellers on… It took off with such bad luck that it was towards me, hitting me. A little pain and a broken carbon fiber propeller. I was lucky :slightly_smiling_face:

I comment on the forum and the teachers that we have here told me the correct way to reset the parameters without doing anything weird. :upside_down_face:

Now looking exactly as it is done I found that they have already posted it on the wiki, Thank you so much guys

Ardupilot Parameter Reset

It is much safer and out of trouble :rofl:

(Greg Covey) #101


Thanks for the tip! I’ll try the parameter reset feature.

(Greg Covey) #102

I got some work done on my Ranger EX upgrade to v3.8.0. As a test, I first just loaded the firmware and saw that without doing the Parameter Reset, I still had the anomaly of quad rotors turning in Manual mode. I then did a full parameter reset from the Mission Planner v1.3.49 button on the Full Parameter List and started recallibrating accs, compass, etc.

I used the Migration from Plane 3.7 to 3.8 page for setup help and did things similar to my other mini Talon QuadPlane project like on-board compass calibration.

I got the Ranger to Arm in Manual mode (love the new arm/disarm with rudder feature) and now only the forward flight motor is used with throttle. In QStabilize mode, the quad rotors were shaky so they did not like the PID settings. I thought I changed them all to my v3.6.0 setup but I may have missed some. I’ll re-check the PIDs and get it hovering properly next. I attached my current .param file below.

RangerEXwithV380QP.param (16.0 KB)

(tridge) #103

can you post a DF log showing that effect?
My first guess is that ESC calibration isn’t quite the same between motors, but that doesn’t explain why the RPM goes up with throttle. Puzzling!

please get a log of the above effect first.
Also, a simpler way to reset parameters if you want to is to set FORMAT_VERSION to 0 then reboot.

(tridge) #104

hmm, one more idea that could explain it. If you have some poor ground connections to the ESCs then it could be ground lift when the forward motor runs causing the ESCs to see bad values. I’d normally use something like a Saleae logic pro with an analog capture to analyse that sort of problem.
First step is a log though, to see if its commanded. I suspect we’ll find it isn’t commanded, and its a electrical issue (eg. ground lift)

(Greg Covey) #105


Thanks for the FORMAT_VERSION suggestion. The “Reset to Default Params” in Mission Planner v1.3.49 seemed to work as well. On my initial hover test using v3.8.0, I was too hasty and didn’t let it get off the ground. A re-test today proved that I am hovering just fine so I am ready to test forward flight next weekend.

The odd hover motor issue appeared after switching from v.3.6.0 to v3.8.0 and back to v3.6.0 without clearing parameters. I don’t see the issue anymore using v3.8.0 after clearing the parameters to default. I can retrieve the log when I get my next test completed on our Labor Day weekend.

RangerEX_QuadPlaneHframeV380ClearParams2.param (16.0 KB)

(rollys) #106

Hello Greg,

I finally convinced myself to fly since the temperatures went down to the mid 80s but humidity was way up there. This flight shows somewhat the same twisting you showed in Post #33 albeit without the wild pitch up but rather a pitch down as it was still stalled as the quad motors ramped down. I’m definitely going to add the guy wires as you did on yours but at different attach points. I know I’m running PX4 but I’m hoping the experiences encountered will help point you to the right direction on getting yours squared away. Good luck.