Quadplane issue

I could use some help figuring out an issue I had on my maiden flight of a quadplane build. I was doing a test flight and checking all the inputs. Roll worked fine, pitch worked fine, yaw right worked fine but… when I gave the smallest input to yaw left with the rudder, the plane rolled hard left and took off. I quickly switched from Loiter to Stabilize which stopped it and allowed me to land safely.

I can’t find the event in the log. If anyone has time to look at it I’d really appreciate it if you could tell me what I should look for in the log and if it reveals the issue, how that was determined. Thanks.

There is a video the flight here https://youtu.be/XHsw8E4YCPE and the logs are located here https://www.dropbox.com/sh/cz04x0zvthnxudt/AAAmy93zQ3D5l4SqaP9D_Ryqa?dl=0


Both logs are showing the QuadPlane is going into RTL mode. You may want to disable failsafes.

Thanks. It seems I’m getting a lot of failsafes due to voltage drops. I’m using two batteries in parallel now and I’ve swapped out the power module as well. More test flying tomorrow. Cheers.