QuadPlane behaves strangely in AUTO with waypoints

My QuadPlane seems to fly well in QSTABILIZE and QLOITER. I haven’t tested the transition or fixed-wing yet. So what’s below is all in VTOL mode.

I tried to load the following mission, hoping to fly it in AUTO so it automatically takes off, waits a few seconds, and then goes to a waypoint.

After it successfully took off, it unexpectedly flew North instead of waiting and following its waypoint, West from its take-off location. I had to take it back in QSTABILIZE mode and go South. The trace can be seen here:

Am I missing something? I should note there was quite a bit of wind but QLOITER works just fine so I’m expecting the aircraft to be able to follow navigation.

After this happened, I decided I was going to test the same mission in APM:Copter and it worked just well. So I’m not sure what is happening with APM:Plane and Q_ENABLE=1.

One strange thing I noticed, as can be seen on the first screenshot with the yellow line going towards the top-left, is MP seems to get confused with the VTOL_TAKEOFF command being at lat,long = 0,0. I’m not sure if this is related to this issue?

I use APM:Plane 3.7.0.

I tried again today and observed the same issue. I simplified the mission to just a VTOL_TAKEOFF and a WAYPOINT. After it successfully takes off in AUTO flight mode, it seems to ignore the waypoint and stays up there, drifting with the wind it seems. What I expect the plane to do is move to the waypoint a few meters away in VTOL mode, since I didn’t ask for a transition.

Here’s the mission as planned.

And here’s what can be seen in the flight data tab just after the flight. It basically took off at Home, reached said altitude successfully. But then unexpectedly it started drifting north east at which point I took over in QSTABILIZE and landed it. It never flew to Waypoint #2.

Question for other QuadPlane users: is it possible to fly such a mission in quad/vtol mode only? Or should I conclude that a transition to fixed-wing needs to happen for the QuadPlane FC to be able to navigate to any waypoint?

As mentioned previously, the APM:Copter firmware works totally fine with such waypoint navigation. In APM:Plane QuadPlane, I also tested a VTOL_TAKEOFF + VTOL_LAND (at a different location), which works fine as well and takes the plane to the new landing location. So basically the GPS stuff works fine.

Here’s a link to a BIN log. That particular flight mission is the last one I did, 28 minutes in. https://drive.google.com/open?id=0Bz8Gb5bfp9T2WlJUOE9WWlYxWnc

EDIT: I’ll add a graph for the relevant part.

Hi…
Check this http://ardupilot.org/plane/docs/quadplane-auto-mode.html

If you want to do a “quad” mission, you have to add transition command after VTOL takeoff command, if no transition command, then you will fly as a plane.

Did you calibrate your airspeed sensor?

I’m not sure I understand what you said. The vehicle already takes off in quad. Kindly explain why I would need a transition command (supposedly to fixed wing) if all I want is a “quad” mission.

In other words, I want to takeoff as a quad (VTOL_TAKEOFF works fine), fly to a waypoint as a quad (that’s the part that doesn’t work), and land as a quad (VTOL_LAND works fine).

read more bro…
Check this http://ardupilot.org/plane/docs/quadplane-auto-mode.html

Mixing VTOL and Fixed Wing Flight
To mix fixed wing and VTOL flight in one mission you can use the DO_VTOL_TRANSITION command in your mission. A DO_VTOL_TRANSITION command takes a single parameter. If the parameter is set to 3 then the aircraft will change to VTOL mode. If the parameter is set to 4 then it will change to fixed wing mode.

http://ardupilot.org/plane/_images/quadplane-vtol-transition.jpg

In the above example the aircraft will do a VTOL takeoff, then it will fly to waypoint 1 as a fixed wing aircraft. It will then switch to VTOL mode and fly as a VTOL aircraft through waypoints 4 and 5, then it will switch back to fixed wing flight to reach waypoint 7, before finally flying home and landing as a VTOL aircraft (assuming Q_RTL_MODE is set to 1).

you have to add DO_VTOL_TRANSITION command and set the parameter to 3 after VTOL_TAKEOFF before 1st waypoint.

read more…
you use airspeed sensor?

Again I do not want to do a transition in this case. Why would I have to add a transition command?

Yes I have an AS sensor.

basicly if you don’t add DO_VTOL_TRANSITION you’re still on plane mode

this is what i do when i want a “plane” mode on my quadplane

_ aircraft will do a VTOL takeoff, then it will fly to waypoint 1 as a fixed wing aircraft_

and this is if i want to fly as “quad” on my mission

OK thanks for clarifying.

With all due respect Nugroho, can someone from the dev team (@tridge maybe?) confirm that without a DO_VTOL_TRANSITION the aircraft won’t fly as a quad?

Also I should add that a mission with only a VTOL_TAKEOFF and a VTOL_LAND commands (at a different location), the aircraft does fly in quad mode to the landing location.

In other words, at times QuadPlane seems to be a bit like quantum theory – neither in one state (quad) or another (fixed-wing).

The way it works is there are mission items (specifically VTOL_TAKEOFF and VTOL_LAND) that are always flown as a multicopter. Normal waypoints are flown as fixed wing unless you do one of two things:

  • you can add a DO_VTOL_TRANSITION
  • or you can set Q_ENABLE=2 to default to multicopter mode for missions
    It works this way as most QuadPlane users want to do their waypoints as fixed wing as that is much more efficient.
    One other thing I would note is that you can fly auto missions as slowly as you like if you set Q_ASSIST_SPEED appropriately. So you can have a DO_CHANGE_SPEED command in a mission and fly very slowly. The VTOL motors will assist with the fixed wing flight to allow it to fly well below the normal stall speed. If what you want is a very slow survey of an area that may suite your needs best.
    Cheers, Tridge
1 Like

Thanks that’s helpful. Two questions to follow up.

  • What is the nominal behavior for the following mission and with default parameters:

    1. VTOL_TAKEOFF
    2. WAYPOINT

where the waypoint is close (say 30 meters away) from takeoff location? In which mode is the aircraft going to fly to said waypoint, using which propulsion mechanism(s)?

  • Since VTOL_TAKEOFF is flown as a multicopter, I assume that when VTOL_TAKEOFF is complete the aircraft is left in multicopter. One could assume that if the next mission item were a WAYPOINT, it would fly as a multicopter. Yet it seems I have to “force” to stick to multicopter by adding a DO_VTOL_TRANSITION(3). Is this correct?

the default behaviour is to transition to fixed wing mode and fly to the waypoint. If it is only 30m away then (depending on your parameters) it may consider that you have reached the waypoint immediately.

no, the default is to fly waypoints as fixed wing. If you don’t want that and instead want it to default to flying them as a multicopter then set Q_ENABLE=2.

I can confirm this works as explained, thanks for the support.