Quadcopter Takeoff issue in Copter 4.0.3

Hi everyone:

I’m trying to make a maiden flight over a S500 quadcopter using a Pixhawk 2.4.8. with 4.0.3 firmware. I performed the respective calibrations: Accelerometer calibration, radio calibration, magnetometer calibration and esc calibration. We tested the motors following the documentation of motor and test ( https://ardupilot.org/copter/docs/connect-escs-and-motors.html) and everything worked

The main components are:
Autopilot: Pixhawk 2.4.8
Motors: RCTIMER 2212/920KV
Esc: Readytosky 40A 2-6S Lipo
Battery: 5200 mAh 4S Multistar
Telemetry: ReadyToSky 915 MHz
Radiocontroller: FLYSKY FS-I6X

When i’m trying to takeoff in stabilize or althold mode, the drone flips. The following video shows the problem.
There is the maiden flight:

And the test using arms

PD: I’m new at this and i don’t know very well how to interpret the logs or detect the failure.

What could be failing?


Seems to me it is caused by incorrect motor and/or prop direction.

If you are using the default Quad-X frame setup, the propellers in your second video show that it is already mounted in the wrong direction.

I realize you said you ran the Motor Test function but are you sure you got it right? Because this is almost always the reason for this.


Post your parameter file or the last Flight Log where you were trying to cut your friends hair.

It seems to me that your CW/CCW props are on the wrong motors.
Your motor 1 and 2 have CW props on them and motors 3 and 4 have CCW props.
Did you try the motors test in MP?
Pay attention that the A,B,C,D order in MP is not the same as motor numbers, so with motor numbering you get motors 1, 4, 2, 3 spining.
Don’t try any other mode than stabilize before you tune your copter.
You may get lucky, but…
Please follow the tuning process instructions: https://ardupilot.org/copter/docs/tuning-process-instructions.html
We were all eager to get our drones in the air, but most of the times it’s wiser to follow the needed steps for a happy flying

Actually the orientation of motor was wrong. We made the takeoff and worked! Thanks for the info guys.

And the friend with long hair was actually me, lol.


Yes it’s for newbie

I think yes it’s look like wrong wiring on your pix

Happy flying :slightly_smiling_face: