Servers by jDrones

Quad want take off correctly, keeps flipping over on take off. HELP!


(Conor Ferguson) #1

Calibrated esc and all sensors but, not really sure whats causing it here are the logs if anyone can help.

https://drive.google.com/drive/folders/1nxtQh6YpJuIu3pj34jDAAabmobuww7qM?usp=sharing


(Conor Ferguson) #2

Also, wanted to mention the flight on 1/12/2018 was run with a different set of esc, when I thought that those esc were causing the issue I first switched the pixhawk2.1 with a tested pixhawk, then after the issue continued I changed out the ESCs and tested again on 1/13/2018 and still has the issue. The quad copter weights 5lbs with 870kv motors, maybe the weight is to much for the UAV to take off, but before I flew to test that with less weight I wanted to see if anyone could tell the issue from the logs.


(Lars Kellogg Stedman) #3

Flipping over on takeoff is often caused by having the motors connected in the wrong order. Are you certain that you have them wired up as described in the docs?


(mike kelly) #4

Some notes
https://www.rcgroups.com/forums/showthread.php?2347545-Troubleshooting-APM-flipping-on-new-build


(Conor Ferguson) #5

I am positive motors are connected right. I can arm and also confirm that the motors are spinning in the right direction.


(Conor Ferguson) #6

The log files are available to see if anything else could be causing the issue, but I can confirm that motor and props are correct. I have a built 1000mm octo, 680 hex, and multiple quads I have built and successfully fly and perform well, I have never experienced a issue like this one I am experiencing now so that’s why I posted the log files to see if anybody can see what is causing the error.


(Richard Mottram) #7

It maybe a faulty motor not generating enough thrust have you tried swapping around to see if it flips in a diffrent direction


(Conor Ferguson) #8

Ill try that out and see if that was it


(Dave) #9

Why are you in Guided_NoGPS mode?


(Conor Ferguson) #10

I was doing that inside the house before I tried to fly the mission to test to see if the motors were spinning and arm up correctly


(Amilcar Lucas) #11

There could also be an issue of octa vs. octa-quad. Are you sure you selected the correct one ?


(Dave) #12

Take it outside and take off in stabilize mode with some authority before determining there is something wrong.


(Conor Ferguson) #13

I selected quad v-tail since its a tbs frame quad copter. I have the logs attached of when I took it outside sent it a mission and it didnt take off right and crashed, but I did not put in stabalize mode before I started the mission. I will try that in the morning.Thank you for your responses, will keep you updated.


(Dave) #14

It should probably be Quad-X unless there is a TBS quad frame I’m not aware of.


(Jagger) #15

All the logs posted in the OP never get above 1180 PWM.No throttle input.No nothing.Possibly lifted a couple of feet due to ground effect but certainly didn’t try to take off.

Try a stabilize flight as Dave suggested.It’s my starting mode for all test flights.


(dazzab) #16

Did you run the motor test in Mission Planner? It’s the best way to confirm that motor order is correct.


(Dave) #17

My money is on the wrong FRAME_TYPE. Set it to X and the problem will be solved. I could be wrong if it actually is a V-Tail but this is far from common and AFAIK TBS doesn’t make one.


(Conor Ferguson) #18

Is tbs discovery frame not considered a v-tail?


(Conor Ferguson) #19

Yes, I also manually test my motors to test for any consistencies by spinning the motors with a drill and a volt meter to see if all phases were equal when motor is rotating. All motors and ESCs are good, but I am taking it out to a area to test in stabilization mode and will get back with you guys. thanks for the help.


(Dave) #20

No. V-tails have odd geometry like tilted rear motors (V) which are sometimes upside down. Set it for X