Quad suddenly flies away during Autotune

Good day, I have an F450 with Pixhawk FW Ardupilot v4.0.6.
I was trying to Autotune it and it was twitching as expected, but shortly after, it suddenly took off, ascending at a high rate. I had to switch to Stabilize mode and landed it.
I rebooted and tried again, but the same thing happened.
Please I need help to go over the log files to know what happened.
I already tried to minimize vibration and had previously disabled an IMU due to some persistent EKF errors.
Any help is appreciated.

activate and tune the dynamic notch filter according to the instructions on the wiki

I finally solved it and the drone flies ok now. I did the dynamic tune, and then followed the instruction for manual tuning. when i tried, it flew better, so i immediately did the autotune and now it flies well.

However, i am still experiencing problems with my other quad. I probably should have mentioned, i am trying to develop a swarm of quadcopters, all f450 with Pixhawk flight controller.
Currently, the other quad (Leader) keeps falling out of the air during flight. I suspect one of the motors is failing or maybe a bad ESC. i checked the log file and discovered that the desired Roll and Pitch values vary when compared to the actual values. The same thing applies to the Desired Alt, when compared to the actual altitude. from the documentation, this is indicative of a mechanical fault. But i am new to this and would like some expert opinions. I also noticed that the motors have different min PWM values. could this be the reason? I want to recalibrate my RC transmitter as well as the ESCs. hopefully this will help, and i wont have to replace motors. Please kindly help again, thanks so much.
i have added the log file.

It looks like thrust loss on Motor 1. Plot the RCOU’s and review. Also your battery looks suspect. It sags ~2V on take-off. And you haven’t set motor thrust scaling: