Quad lifts off and lands (crashes) immediatly [solved: was bad battery]

Hi, I’m quite a newbie so please forgive errors and inaccuracies.

In a few words, the problem is that my Quad lifts off 1m /1,5m at full throttle and after seconds lands/crashes.

…with more detail:

During setup, I followed carefully and exactly the steps described in Arducopter documentation, how to’s videos and did ESC calibration many times… but the result was always the same, little take-off and then a crash, like if the Quad were too heavy for the provided motors/propellers.

I repeat: it lifts off 1.5 meters only at full throttle.

I tried to look in this forum for similar problems as well but without success. Also, the collected logs look still a little unfamiliar to me. :slightly_frowning_face:

I’m asking for hints, controls to do, suggestions or whatever I have to do in this case to troubleshoot this problem and let this Quad fly :slight_smile:

to give you more specs

Thank you in advance for any help.


Please collect and provide logs :slightly_smiling_face:
Here is details about: https://ardupilot.org/copter/docs/common-downloading-and-analyzing-data-logs-in-mission-planner.html


Here are the .bin files of 3 yesterday crashes… I can provide the .log too if needed or better…





@Francesco_S Sir,
Make this change and do the test again Sir.
Source is https://ardupilot.org/copter/docs/tuning-process-instructions.html#test-althold

Thanks and regards

Your motors are commanded to Max, battery voltage sags to <2.8V/cell and it’s not flying. Over loaded/ Under powered.

What motors, props and Take Off Weight?

Thank you!

I’ll try it out and come back!


Here are the specs:

  • Motors - 2216 KV880( V2 Update)
  • Propeller 1045( V2 Update)
  • Take Off Weight 1400g (battery included)


That should get off the ground but it will be underpowered. Or your weight estimate is off. It’s a HolyBro kit? They say it weights 1320g w/o a battery. Anyway it’s underpowered, no amount of parameter fiddling will fix the basic problem. Buy a 4S battery that will bring the Take Off Weight to ~1700g and you should be good,

Thank you Dave,

I weighed the Quad by myself right now, it is equipped with a 4S/5000mAh/50C battery and confirm that it weight is 1430g battery included (503g)


OK, then you have a battery problem if it’s a 4S battery or your battery monitoring is way off. Look at the battery voltage in your logs. They start ~11V (2.75 V/Cell for 4s) and drops to ~8.5V (2.1 V/cell or dead) under load. Was the battery supposed to be fully charged when these logs started?

@dkemxr probably voltage divider is wrong? but anyways sag is tooooo big

When I started battery was around 14,5 V :thinking: … effectively I’ve to investigate in that direction!


Well, it would be a good idea to start with a fully charged battery…

1 Like

The voltage multiplier is at the default value (18.182) for a Pixhawk 4 so not sure.

Voltage Divider seems correct… (18.182)

for “sag” you mean the potential difference (10.5 -> 8.5) during the throttle increase? (sorry I’m not native english)

effectively everything seems going toward a battery failure…

Yes. 10.5V is already way too low for a 4S battery and the sag is in dead territory. This is why I assumed you were on 3S. So yes, I would suspect the battery as well.

1 Like

dkemxr is 100% correct. You have a SERIOUS problem with that battery.

battery changed… everything flies as it should :star_struck: :pray:

Thank you all