PX4FLOW Enable problem

Hi there
I want to use px4flow to implement loiter mode instead of using GPS module.
I followed steps in this site: https://ardupilot.org/copter/docs/common-px4flow-overview.html?highlight=px4flow

However I cannot click enable button in Mission Planner
Initial Setup | Optional Hardware | Optical Flow | Enable


I have tried to set flow_type = 1 in parameter tree,and connect px4flow to px4mini through i2c,
but values about flow is still zero(opt_m_x,opt_m_y…)
擷取

Also,I’ve tried connecting px4flow module through usb to computer,and I can see the value changes in mission planner.I just cannot use px4flow when I connect it with px4mini.

How can I solve this problem?

Hi, I am having a similar issue with Cube Orange Copter 4.1.

The check box in the Optical Flow Tab is grayed out and cannot be clicked.

I have followed the guide provided by the wiki for the PX4Flow, but i can’t get data or video even when I plug into the PC directly with USB.

Have you found any solution?

Hi, I suggest you can use Qground control, I can see the camera scene from QGC.
Also, I’ve tried to use older version of mission planner and it can see the camera scene.
(I forgot which version sorry).
The provided firmware from qgc and mission planner is different and I am not sure which one is more accurate.