PX4 not working?

Hi!

I have a PX4 FMU 1.6 with the PX4IO 1.3, I havent being able to make it fly…

When I got this from 3DR, the didnt send me the button or the buzzer, so, I have to buy those two components on “mouser electronics”, a regular 5v buzzer and the LP1OA1AG, and now that I have everything, I used APM Planner 2 to upload the newest firmware, I tried it on mac first, and it hangs at 99% saying “verifying version” so, I quit that, and use windows to it, and in Windows works, the firmware is uploaded correctly. I have to issues with it:

1.- I have a Orange R800x with S.Bus port ( hobbyking.com/hobbyking/stor … duct=38392 ) When I plug it to the PX4, and use APM planner to calibrate the radio, nothing happens… I tried connecting it in the 2 possible ways and nothing… So, is the RX not working or the PX4?? so, I have to use a ppm mux, connecting the 8 channels, and that works… But why the s.bus is not working???

2.- The GPS never has fix

3.- When I connect everything, ESC’s, battery, and turn it on, it makes a nice startup noise, and then the button blinks, so, I proceed to wait like 20 secs, and then press the button, but it never stops blinking, and I’m unable to arm…

I’m not sure the PX4IO has a correct firmware…

Any ideas? help?

Cheers!!

  1. could you try using a ppm_sum board thingy to send the rx signals. I tried using a frsky rx to send sbus signals but it didnt work. tried a futaba one, worked flawlessly.

  2. which gps are you using?

  3. which firmware are you using?

Sent from my GT-N5120 using Tapatalk

updates:

1.- I was able to upgrade the firmware on the PX4IO, it was because of voltage, I needed to update firmware connected to a battery, USB power will not be enough… Then after the update, I was able to read the S.BUS from my RX, the only thing is that pitch and throttle are mixed, I might have to see if my 9XR can change the order on the channels???

2.- uBlox, still no fix… :frowning:

3.- The new one, I used APM2, and automatically update to the 3.1, I haven’t tried older firmwares, should I??

And now I have a new issue, hehehe, everything connected, radio calibrated, all ready to fly, so, I push the button, makes some nice noises, and stops blinking, then I proceed to arm with the stick, yaw to the left… nothing… then proceed to try with the 2 sticks, yaw to left, roll right / pitch down… and nothing… its my first time arming the PX4, am I doing something wrong here???

Cheers!!

have you checked if your channels are reversed? you may be giving th wrong signal unknowingly.

for ublox check your wiring again. if its correct, contact customer service. seems as though you have a faulty gps

Sent from my GT-N5120 using Tapatalk

mmmm

If I put the gps on a APM, the GPS makes a fix… but if I unplug it and put it in the PX4, then this happens (see attached)

LAT: 0
LON: 0
FIX: 1
SATS: 0
HDOP: 1e+0

what do you think??

cheers!!