Problems w/ Copter 3.5 Beta RC1 Tri on Pixhawk mini

Currently in firmware hell. 3.4.5 not compatible with pix mini so I have tried 3.5 beta & master.

Motor/ESC combo (480kv)

Not able to calibrate my emax ESCs. I was able to do this on master 2-3 weeks ago but not now. ESCs just beep. Able to calibrate as usual on PX4 FW & with my old FC. Tried to force calibration with ESC_CALIBRATION parameter but no luck. Flashing red, blue & yellow LEDs & then a 3 tone buzz. Pressing arm button causes ESC beeping, another press causes arming tones in ESCs, next press & motors spin up.

Beta 3.5 crashes QGC 3.1.2 after FW is first loaded. Master 3.5 crashes QGC every time I connect to vehicle now but didn’t do this when I was playing with it 2-3 weeks ago.

FRAME_CLASS parameter keeps resetting to 6 every time I power down the vehicle. I keep setting it back to 7.

Yaw servo (ch7) was unresponsive. Didn’t look too deeply into the parameters because I was pretty frustrated by this time. Switched back to PX4, unfortunately. Switching back & forth gets old because motor maps are different & wires are tucked deep in airframe.


I’ve replied on the other thread but just in case anyone is reading this, the issue is that it seems the incorrect firmware has been loaded (Heli has been loaded instead of Tricopter). For Tricopter, the MP has a special TriCopter icon - I’ve just tested this and for AC3.5 it seems to work correctly - it loads the consolidated multicopter firmware.