Problems on setting environment (Eclipse on Windows 8.1)

Hi everyone,
I am new in Ardupilot and I am trying to setting the environment on Windows following this guide

I cloned the repository and downloaded the toolchain, and I managed to create a project from a template
on Eclipse Juno (the one provided downloading the toolchain).
The problem is that when I open an ArduCopter class (the one I am interested to) there are lots of compiling errors like the following on these screenshot.

I can’t understand what I am missing and I don’t know what to do anymore
I also tried to follow the guide for Linux, but in the end I get the same error
What should I do?
Where did I go wrong? I missed some inclusion or to download something?
Thanks everyone :wink:
EDIT- after I posted this I saw that the images aren’t so clear, so the error are


Method ‘update’ could not be resolved.



The type ‘GCS_MAVLINK_Copter’ must implement the inherited pure virtual method ‘GCS_MAVLINK::handleMessage’


    AP_Arming_Copter(const AP_AHRS_NavEKF &ahrs_ref, const AP_Baro &baro, Compass &compass,
                     const AP_BattMonitor &battery, const AP_InertialNav_NavEKF &inav,
                     const AP_InertialSensor &ins) :
        AP_Arming(ahrs_ref, baro, compass, battery),

Symbol ‘AP_Arming’ could not be resolved

1 Like

Hi Alessandro,

I’ve never used Eclipse with ArduPilot so I can’t be of great help. What you are seeing is Eclipse not finding the places where those methods are declared and defined - I’m not sure something can be done about that. You should still be able to compile using the make commands.

@rmackay9 Any advice you can give here?

I just found out that Eclipse can’t handle all the includes, so that was the problem.

Did you find a work around or is there no way to get Eclipse to handle the includes? I’m having the same issue with Eclipse on Windows10.