Servers by jDrones

Problems connecting to Mission Planner with Matek H743-SLIM

Hi all.
I’ve been setting up a quadcopter using a Matek H743-SLIM as the FC. I flashed Copter 4.0.5 Stable successfully but when I connect it via USB and connect with Mission Planner, it goes through the parameter downloading and seems to finish correctly but the HUD doesn’t move when I move the FC, nor do any of the telemetry values change on the Quick panel.

If I then disconnect MP, connect MavProxy, then disconnect it and reconnect MP, then the HUD moves as normal and the Quick panel values update correctly.
I have tried reflashing AP, but still the same results.

If anyone has any ideas on how to solve this it would be much appreciated.

Below is a BIN log from letting it start up with LOG_DISARMED enabled if that is of any help:
https://drive.google.com/file/d/1Up6jU-bnTPJLl7FTANeDoq4DUOrHIxQZ/view?usp=sharing

Thanks.

Thought I’d come back here and update in case it helps anyone else.

Turns out the stream rate settings on MP had gotten set to -1 at some point previously, which means it takes the stream rates that the previous ground station software has set or defaults to zero if no ground station has connected before it since boot.

1 Like
Servers by jDrones