Problem connecting Pixhawk with Futaba receiver


Two of my customers have trouble setting up the Pixhawk - I myself have a Pixhawk, but don’t use a Futaba receiver, thereby I can’t replicate the problem (I would like to find out if the problem is connected to the receiver they use, or something else).

Both use a Futaba R7008SB receiver.
Both managed to upload the Firmware to their Pixhawks - but they are not able to do the radio calibration (the Pixhawk doesn’t “see” the receivers, the bars in the calibration are all grey).

They have nothing else connected to the Pixhawk, except receiver (connected to the right port / RC), buzzer, safety switch and USB cable.

The Pixhawk signals via the big LED “pre-arm check failed” (which makes sense :wink:

They power the Pixhawk via USB and at the same time with a LiPo (via the Power Module).

The receiver is “found” by the remote, the LEDs are on, the setting of receiver and remote (regarding the use of the SBUS) seems to be right. They use the right port of the receiver to connect to the Pixhawk.

I am happy about any suggestions …

Thanks a lot in advance


I sure hope we get a solution for this ASAP. I just got notice that my Pixhawk is in the mail and I am using a Futaba R7008SB receiver. That’s the only receiver that works with SG14 telemetry so all Futaba SG14 owners will need an immediate solution. I will be very disappointed if I waited all this time for my PixHawk and won’t be able to make it work. :angry:

Also there are two ports on that receiver. Sbus and Sbus2. To get Sbus you have to make sure the receiver is set to the correct mode. Maybe that’s the problem. The receiver instructions explain how to set the correct mode.


I have asked my customers - they said they put their receiver in the right mode …

For everybody who wants to have another go at changing the receiver mode, there’s a video: … QtvsCvLDe7