Problem CH6 tuning

Help please. Trying to sort out my sons copter. The MIN/MAX values for CH6 tuning are greyed out no matter what parameter is chosen. In RC calibration CH6 works fine. We have even tried entering in full parameter tree and writing but they default back to zero. He has a ‘pixhack’ FC.
It works ok with my cube black so not a MP problem.
Any ideas please.

Try updating Mission Planner to latest Beta from the Help screen. This will likely fix the inactive menu on the Extended Tuning screen. But it’s odd that saving the changes in the Full parameter list wasn’t persistent unless the ranges were not right. What parameter and what ranges are you trying?

I just tried min -0 max -0.1. thought it would just generate a warning if they were out of limits.
MP is latest but not beta

What parameter are you trying to set? Anytime you see an issue with an inactive screen element update to latest beta.

We just want to tune (PID) using CH6, like we have done for years but any parameter chosen from the dropdown list dosent work and min/max values are inactive.

I get that, there are many PID parameters to choose from, which one are you trying to set from 0 to -1?

Have just tried TUNE_MIN 0.1 TUNE_MAX 0.19 in Kp. Actually these values seem to write and are still there after refresh, however the min/max in extended tuning are still grey and zero. The CH6 is not changing Kp or anything else.

I don’t see it grayed out but there is a problem using the Min and Max range boxes to set these parameters. However, when they are set with the full parameter list is works, is persistent and changes on the Extended Tuning page when my Chan 6 knob is turned and the Refresh Screen button is pressed. So it’s working there just seems to be an issue with the input boxes with this latest Beta. Wait a few days, it will probably be fixed…

Hi guys,

Any update on this issue perhaps? I updated to the latest beta version just now but I am still seeing the issue with the input boxes in MP not working.

Forget about the input boxes, someday they will work. Simply use the Full Parameter List:

I’ve done exactly that yes thanks.

I did however notice that if you try to enter any value in the input boxes it gets saved to BOTH the min and max field which could be dangerous especially if one doesn’t notice it…

Yes, I noticed that. I’m in the process of Live Tuning and after I make the change in the Full Parameter List I check the entered range with my radio on the Extended Tuning page by turning the pot min to max and “refresh screen” after making the change and confirm it’s right. It’s a good sanity check.

I haven’t flown my quad since July 2018 when I replaced my old APM1 controller with a Pixhawk. I got as far as doing one test flight but it was very unstable and a hard landing broke a few things. Now with our country being in lockdown because of the Corona virus outbreak I thought I would try and get it back in the air again.

You may not have seen the newer tuning guidelines. Follow them before making the next flight.

Thanks I stumbled across it yesterday already. I managed to get my quad airborne today and after one wobbly landing whilst tuning I settled on a slightly lower Rate/Roll P of 0.1.

My compass is a few degrees off however so tomorrow I need to try and sort that out and also calibrate my battery voltage/usage again.