Servers by jDrones

Problem althold, attitude hold, heading hold

Hello Chris,
why should it set to airplane? it is sending the pure signals, without any mixers or other Heli-specifies.
and in mission planner i can see the correct swithing to althold.

my Friend, using the same program, is also flying in heli-mode.

Holger

Doesn’t it automatically link channel 3 to channel 6? Due to the pitch curve and throttle curve mixing? Heli mode for a transmitter is just not good for Ardupilot. You will want to use the transmitter channel 6 in order to adjust or conduct tuning using your transmitter as input. You won’t be able to do this with a Heli mode in your transmitter because of that mixing in the transmitter.

It is easier to set up the aircraft with using an airplane mode in the transmitter.

Hello Bill,
I use the frysky X12S. in Servo-Monitor i can see, that it transmits the pure, unmixed signals for each channel.

I will ask my friend, what mode he is flying. He has se same TX.

Holger

Ok this is good. As long as you see unmixed signals in the servo monitor, you are in good shape.

Holger,
Please set your LOG_BITMASK to 131071 before you conduct your flight. If you like, please send me a log of your test you are conducting on the bench where you are seeing this swashplate behavior you are concerned with.

Hello Bill,
I will do when weather becomes better…

Ain ardu-wiki i found under “altitude hold” this text:

“AC3.1 and later allow arming and disarming in altitude hold mode. When disarming, the copter may need to rest in the landing position for a few seconds to allow the “landing checker” to verify that the copter has landed before you are able to disarm.”

could that be a reason for my problem with swashplate moving down?

I also tested some steps in thr_dz 0 - max (300), but no reaction (it was on 100).

And as i said: my friend hasn’t that problem with my paramfile and same TX.

And to your profile-picture: You are a heli-pilot in Army? great! i’m a private pilot on plane.

Holger

I don’t believe so. If you could do a test with the engine off in your workshop, that might help me understand what the swashplate is doing. It sounds like you could do it safely since your engine is linked only to your rc receiver. but would be good if you could disconnect power to ESC just to be sure. Enable LOG_DISARMED. flip it to althold and then back to stabilize. then you could arm the flight controller and enable motor interlock. Let the runup timer expire and then flip to althold. then disable motor interlock and disarm and post the log file. be sure to disable LOG_DISARMED after you are done.

No, not a pilot. I am a flight test engineer with the Navy.

Hello Bill,
all is good !!! and works fine!!! (on the bench)

All big things ar easily!

I had the FW 3.6.10. The mission planner asked me to update to the new 3.6.11
I did and thought, it is the latest. (but with no changes)
But it wasn’t. The latest is 4.0.0
I made update to it - and now all is running fine!

next days i try flying.
Then i will report (and have perhaps new questions)

But first thank You very much for Your help!

Holger

No. Do Not Fly 4.0.0!! that has not been released as stable. Please stay with stable versions of the software. Currently that is 3.6.11.

Hi Bill,
after not running arm, motor interlock and so on, i found this (with 3.6.11)

grafik

pressing Arm / disarm comes this:
grafik

pressing “force arm” all is going! no further arming needed. Althold with stick-reaction, holding in acro, even all I want.

Please tell me: can I program a switch in transmitter for that?

Or better: because there is this function, it must be able to deactivate ALL arming requieres in List / program / Fc or other.

I need no arming, because i have no copter and know, what i do. The normal FBL-system for helis dind’t have such routines too.

can you help?

Holger

This is not recommended. You are taking a BIG risk arming with failing pre arm checks. This pre-arm check is easy to fix. But you may have others that if you ignore the pre-arm check and continue to fly will cause you to crash.
So this system has some safety features to keep you from accidentally starting the motor. The sequence for flying the heli is to power the heli and let the flight controller go through the power up sequence. Part of that is calibrating the IMU’s and also getting GPS quality to an acceptable level. Once the flight controller completes the pre-arm checks, it will give you a green flashing light. Part of the pre-arm check is having your motor interlock switch (you may be use to the term throttle hold) disabled (throttle hold on). Now you can arm the flight controller. Once armed, you can then switch motor interlock enable (throttle hold off). This will tell the ESC to spool up the rotor to operating RPM. And then you can takeoff. If you have the aircraft in Loiter or Althold, it won’t let you takeoff until the rotor runup timer finishes which is set by the parameter H_RSC_RUNUP_TIME. This ensures the rotor has completed the spool up.

I believe you said that your ESC is directly connected to your receiver. I don’t think that is a good idea. It bypasses some of the safety features of this system but that is up to you. In order to fix your problem above. Assign a transmitter switch (maybe your throttle hold switch) to channel 8. have it set so throttle hold on position has the output to the pixhawk be low and the throttle hold off be high. You will have to have this in the throttle hold off position to arm your heli and then switch it to throttle hold off to fly your heli. There are flight control features hooked to this switch so you definitely want it in the throttle hold off position to fly. That is why it would be better to use the pixhawk to control your ESC.

Hi Bill,
thank you for your care - but don’t worry!
I’m not using the pix in the big tandem from the fotos. I use it in my old experimental frame without fuselage, in which I try all new things. it crashes sometimes and is quickly repaired.

so - please tell me how to fix it. its my risk, and when i crash, I tell yöu of course.

But additionally i can try again the “normal” way. Please explane in small an easy steps, what to do. Because i don’t understand all from your descritpion - also not with google translater.

I have:
3.6.11 / reset to default
frame class 11 / frame type 1 (=heli dual)
servos (motors) 1 - 6 are each 3 servos for the swashplates
ch7 is “disabled” / ch8 is “HeliRSC”

I can’t arm with the stick, the two beeps are decreasing (= no arming)
but i can move the rudders

as before, in “althold” the swashplates moves down, no reaction possible.

in live display and messages i have always “PreArm: motor interlock enabled”
(in other topics in this forum some other guys have the same Problem)

There is no need to care with the motor run. i switch it on and off, and i can see / hear, when it has his correct rpm.

The ESC is directly connected to receiver ch8. it runs in gov-mode with two rpm’s
100 % = off / -15% = first rpm / -33% = second rpm ( if needed, i can try to switch vice versa to positive numbers).

on ch7 in receiver i have a switch (for ch7 in extended menue for choose an action).
I tried here “motor interlock”, but no reaction, same message.

so it was all the time before too.

Holger

This is servo out. This looks good.

In your case the easiest thing to do would be to use a channel option to set motor interlock. It looks like that was what your friend did. Pick an RC transmitter channel that you want to use a switch for to enable/disable motor interlock. Then set the parameter CHX_OPT for 32. Where X is the RC channel you are using to switch motor interlock enable/disable. You can also do this with arming rather than using stick arming.

Hello Bill,
i am near dispair - nothing works.

For test I took channel 10 and gave him the “32” for motor interlock. but further it doesn’t work.
arming just like that doesn’t work too

Then I reinstalled MP and installed the “older” 3.6.10 in pix - no change.

I repeat: Please show me how to disable ALL arming routines like shown on fotos from MP first site / “force arm” !

Holger

Holger, I am sorry that you having so much difficulty setting this up. You can bypass arming checks but you have to have motor interlock working correctly. The helicopter will not fly correctly without it.
I am asking a German speaking user to see if he has time to help you get this resolved. Hopefully he has time and can help you.

hello Bill,
thank you, that would be nice!

Holger

Hello Bill,
today i was on the field. With 3.6.11 and the arming-problems it was of course not good flying.

so I loaded again the 4.0.0.

And as i said: all was fine, no messages, the behavior seems typical to the flight-modes. If I could change the params of PID, it would be perfect.

But now a new problem: I can’ get a connection to the MP ( I had that some days ago too).

There is nothing to make (PC and notebook).

I tried all: connect / disconnected the RX / GPS / battery / other USB-cable …- no change.

no connection, always the message “no heartbeats …”

I can change back the firmware (3.6…) - sometime after a few tries - but further no connection to MP.

I saw in this and other forums, that often people has problems with " Connection …no heartbeats", but get no solution.

Do you have an idea?

Holger

Hallo Holger,

Bill hat mich auf Dein Problem aufmerksam gemacht und gefragt, ob ich nicht helfen kann.

Also erstmal vorneweg: Tolles Projekt! Der große Heli sieht richtig klasse aus und ich bin sehr gespannt, Deine weiteren Fortschritte damit zu verfolgen. Ich selber habe einen T-Rex 800 aufgebaut, der inzwischen sehr gut mit Ardupilot fliegt. Mittlerweile bin ich absoluter Ardupilot-Fan geworden. Von daher bin ich mir sicher, dass auch Dein Projekt gut funktionieren kann und Du viel Spaß damit haben wirst.

Nun zum Inhaltlichen: Ich glaube, dass das im Moment größte Problem darin liegt, dass Du den Gaskanal am Flugcontroller vorbeischleust. Vielleicht ist das theoretisch auch machbar, aber ich würde es auf keinen Fall empfehlen. Einerseits verlierst Du die zusätzliche Sicherheit, dass Dein Motor nicht versehentlich anlaufen kann. Mag sein, dass das bei herkömmlichen Flybarless-Helis auch nicht vorhanden ist, aber bei dem Ardupilot-Heli wirst Du wahrscheinlich viel Zeit mit Einstellarbeiten verbringen. Da kann sowas wirklich nicht schaden. Andererseits verlierst Du dabei aber auch die Failsafe-Funktionalität im Flug. Wenn bei mir beispielsweise Sender oder Empfänger ausfallen (oder ich einfach keine gute Funkverbindung mehr habe), wechselt der Heli automatisch in den Failsafe-Modus, fliegt zum Startplatz zurück und landet dort. Wenn Du den Gaskanal am Flugcontroller vorbei leitest, wird der Motor einfach ausgehen.

Vermutlich könntest Du durch ein Versehen sogar im Disarmed-Zustand fliegen. Der Flugcontroller funktioniert dann in einigen Punkten anders, was ggf. zum Absturz führen könnte.

Ich vermute, wenn Du den Gaskanal ganz normal durch den Flugcontroller leitest, verschwinden Deine Probleme bezüglich der Prearm-Checks auch von selbst. Ganz wichtig ist aber auf jeden Fall, dass im Sender alle Kanäle (auch der Gaskanal) von -100 bis +100 gehen. Hast Du die „Radio calibration“ gemacht? Wenn Du die Wege verstellst, muss das natürlich auch neu gemacht werden. Da gibt’s übrigens zwei kleine Fallen:

  • Der Kanal „Pitch“ hat nichts mit unserem deutschen Pitch (also kollektiv) zu tun. Der steht für Nick.
  • Wenn Du Nick nach vorne steuerst, muss der „Pitch“-Kanal im Wert ABNEHMEN

Alles andere ist intuitiv.

Nun zu Deinem Problem mit MissionPlanner:

Hast Du den richtigen COM-Port gewählt? Rechts oben in der Ecke wo Du den einstellen kannst, gibt es auch die Möglichkeit „Auto“ auszuwählen. Das dauert einen kleinen Moment, hilft dann aber meistens. Ansonsten versuch mal im Windows-Gerätemanager durch Ein- und Ausstecken herauszufinden, welchen COM-Port Dein Telemetriemodul hat. Funktioniert denn die Verbindung über USB? Baud rate ist für USB 115200 und für die Telemetrie 57600. Steht auch alles nochmal ausführlich hier beschrieben:

http://ardupilot.org/copter/docs/common-connect-mission-planner-autopilot.html

Ich hoffe, ich konnte Dir ein bisschen weiter helfen.

Viele Grüße

Felix

Hallo Felix ( und Bill)
danke erstmal für die Vermittlung und Deine (Eure) Hilfe. Ich werde morgen noch mal näher drauf eingehen.
Bis dann !

Holger

Hallo Felix,
so nun komm ich dazu. Nochmals danke fürs Kümmern!
ein 800er ist ja schon mal eine amtliche Größe, sehr gut!
Das Tandem-Projekt betreibe ich seit fast 10 Jahren und habe mir fast alles selber beigebracht ( und weiß auch alles…), damals gabs das noch nicht so richtig. Die Mechanik ist eine Eigenkonstruktion mit Riemenantrieb.
Mein neuester Clou sind die Rotorköpfe. Sie sind auch eine Konstruktion von mir, sie sind in Größe, Design und Funktion absolut vorbildgetreu und - 3D-Druck im Laser-Sinter-Verfahren. Das ist absolut neu, bin ich vermutlich der erste und einzige mit.
Wenn Du die ROTOR liest, kennst Du meinen Bericht darüber, sonst sende ich ihn Dir noch mal zu.

Wie kam ich auf Flightcontroller?
Das Teil fliegt mit dem bisherigen FBL (Bavarian Demon 3SX) absolut super, ist auch das einzige mit Tandem-Programm.

  1. mein Wunsch war, den Tandem mit GPS “in die Luft zu stellen”, um Heckklappe, Seilwinde usw. in Ruhe zu bedienen. Leider ist für das 3SX trotz Ankündigung keine GPS-Ergänzung in Sicht.

  2. dachte ich schon immer, dass der Tandem doch auch mit einer quadrocoptersteuerung zu fliegen sein müsste. Der Tandem wird ja über je 2 Servos vorn und hinten angeteuert. Und die machen das gleiche, wie die vier Motoren von einem quadcop, auch von der Charakeristik her.
    Habe ich mit DJI naza-M probiert - und geht.
    Aber das kann ja nur Motoren ansteuern. ich brauchte etwas, um statt der vier Motoren vier Servos mit den üblichen Einstellmöglichkeiten (Mitte, revese, Wege usw.) anzusteuern.

So kam ich durch Hinweis von einem Freund auf FC. Und da MP mit Pixhawk.4 mini.
Und da im Programm habe ich gesehen, dass der ja auch eine Tandemsteuerung hat (Heli-Dual, Frame class 11). Damit war die Sache eindeutig. Vom Prinzip funktioniert das auch super.

ich hatte zunächst die FW stable 3.6.11 drauf. Die ging auch im Prinzip, aber das armen war immer ein Problem und dazu kam “PreArm motor interlock enable”, was durch nichts wegzukriegen war (wirklich alles probiert).Und es ging nur bei acro und stable. Bei allen Modi mit althold gingen die Taumelscheiben auf Anschlag runter und waren durch nichts zu beeinflussen. Wieder alles probiert (mit Bill) - nichts.
Bei meinem Freund ging alles, er hatte aber auch auch die neuste FW (latest) 4.0.0 drauf.
Ich also auch - und es ging alles! armen kein problem, interlock nicht aktiv, keinerlei Fehlermeldungen.
Auf der Werkbank war alles so, wie es typischeweise sein sollte, auch althold.

Ich hatte einmal kurz Gelegenheit, damit auch zu fliegen - vom Ansatz, wie es sein sollte. Jetzt fehlen aber natürlich noch die richtigen PID-Einstellungen.
Aber nun kriege ich keine Verbindung mehr zum MP. Ich habe vielfach alles versucht (natürlich auch Deine Tips) - aber nichts. Port, Baud usw. alles ok. anderer PC, andere Kabel, anderer USB - nichts geht mehr.
Andere FW aufspielen geht manchmal nach mehreren Versuchen, aber dann auch keine Verbindung.
Bei beiden (connecten, neue FW) kommt immer diese Fehlermeldung:

grafik

In den verschiedenen Foren habe die Leute offenbar öfter das gleiche Problem, allerdings ohne brauchbare Lösungen. (bei Interlock übrigns auch).
Kann es sein, dass einfach der pix kaputt ist? 3 Wochen alt, und vorher ging ja auch alles.

Wenn Du da eine Lösung hast, bist Du der Größte !!

Und nochmal zu den arming-Sachen.
Ardu und MP ist ja offensichtlich zuerst und hauptsächjlich für Copter entwickelt. Bei dem machen die ganzen arming-Sachen ja auch Sinn, weil ja alles nur über laufende Motoren geht.
Beim Hubi passiert ja nichts, solange ich nicht bewusst den Motor einschalte. deshalb brauche ich diese ganze “Sicherheiten” nicht.
Deshalb wäre es mir am liebsten, wenn man alle arming-Sachen im Menue ausschalten könnte.
(mit nur einmal armen bei 4.0.0 könnte ich ja noch leben…)

Über Anschluss des Reglers an den FC könnte man nachdenken, da müsstest Du mir dann genau das Vorgehen beschreiben.
Bei einigen neueren FBL’s kann man den Regler auch daran anchließen. Das hat aber wohl weniger mit Sicherheit zu tun, als die direktere und schnellere Regelung im FBL bei z.B. Lastwechseln.

Ich würde ja auch gern ein FC-Fan werden. Aber wenn ich mit dem Laptop auf der Wiese bin und keine Verbindung kriege, wird das nichts!

Also erstmal viele Grüße aus Hamburg - woher kommst Du?

Holger

Servers by jDrones