Pre-arm Rangefinder error

I am using Pixhawk 2.1 as flight controller for quadcopter.
I am getting a “Pre-arm check rangefinder” error.
But, if I lift the quadcopter to a height of about 50 cm, the error disappears.

This error just started coming now i.e. wasn’t coming before.

I am using Lidar Lite V3 for distance measurement.

Can only this check be disabled through Mission Planner?

What is the reason for this error?


Have you tried to read the documentation ?

By default, on Copter if you have the LIDAR enabled, it will check LIDAR range on startup. To pass the check, lift the vehicle up at least 50cm. Don’t tip it over too much because the check is a bit sensitive, it needs to see a range of between 50cm ~ 2m but nothing longer than 2m. If it sees a range longer than that, it’ll never pass unless you reboot the board (nicer solution to this coming soon!). The check can be disabled by setting ARMING_CHECK to Skip Param/Sonar.