Pre arm Logging not started

Hello to all,

I setup a new quad copter , everything looks good but i cannot arm because always fail to pre arm with the msg logging not started, i already changed sd card to a brand new but still the same msg .

I know i can disable logging fail but i do not want ,so can someone help me to solve that problem.

Best regards.

We need a bit more information please.

  • What FC are you using?
  • Is it a fast speed SD card or a cheap slow version?
  • What options have you selected for logging?
    …perhaps you’ve selected an option that is not supported by your FC. …just one thought.


I use orange cube with Lexar UHS-I sd card up to 100MB/S you can see my options at screenshot

I assume you have at least 500MB free space on SD card?

yes that is correct i got at least 10gbs

That sounds all good.
I would then start to reduce logging options to just one or two. Try that and if it works it must be one particular option causing the issue.
…I guess you have GPS installed?

Still the same it is very strange

The only other thing to try would be using the LOG_FILE_RATE_MAX setting and try something like just 100 and once more test it. If it doesn’t change anything revert back to the default 0 value.

There is bound to be someone on here who has more experience with logging related issues than what I have.
Best of luck.

well still the same message it start to become really annoy thank you for the help mate, please any developer to help

Try disabling LOG_REPLAY.


Still the same result

We can close topic actually it was a broken sd card reader of A/P Rma procedure is already started.