Pre arm: Bad EKF attitude and other problems

Hello all,

I am getting in trouble with a project of a 6inches quad using a Matek F405 STD, arducopter 4.1.0

I built the first quad and was working on the configuration. I am quite happy with the configuration so I build 2 more of them.

These ones are the ones giving me problems. When I flash ardupilot and conect them to the GCS via USB I am getting the GSpeed increasing with the time, but the quads are sitting on the Table. I also get Pre arm: Bad EKF attitude and Bad Baro Health. I always plug the battery first, then the USB cable.

I should be doing something wrong, because the problem is identical in the other 2 drones, and the first one works fine.

I have tried to install several firmware targets:




But no one works fine. I stay away of the ones with Heli on the name, cause I assume they are for helicopters.

I would really appreciate some help cause I am a bit stuck.

Thanks in advance.

Why are you not using the latest stable ArduCopter-4.1.5 ?

Why are you using a version that has bugs known to be fixed in the 4.1.5 version?

How good have you calibrated the compass? Outdoors? with GPS signal?

Hello! Thank you for your answer.

I was using that version because back in the day it worked and when something works… I do not like to change it.

I calibrated everything indoors. With no GPS. Im going out right now to do it with GPS and see.

I just came from outside. I calibrated the compass outdoors with gps signal in both the gps. The problem still persists.

This is driving me totally Crazy.

I have updated the drone that works by the STM32Cube programmer to the last 4.1.5 MatekF405-STD version.

When I first plug it (plugging the battery first), the EKF on the hud is white, and the GS (ground speed) indicator has a normal behaviour.

When doing the same with the other drones, the EKF on the hud is red and the GS is increasing with the time and doing funky things in both of them.

I tried to take a brand new Matek F405-STD straight from the original Package, because I have a bunch of them. I Did the same process with STM32Cube programmer to the last 4.1.5 version for Matek F405-STD. I was powering the board with a BEC and connected via USB. The behavior was the same than in the other 2 drones. The EKF on the hud is red and the GS is increasing with the time and doing funky things.

I have no clue what is going on here.

Could you post logs showing both the good and bad behavior?

I generated them just by trying to force the drone to arm. Thank you in advance.

Both of those logs contain this message:
1969-12-31 17:00:32.977 Frame: UNSUPPORTED
and this one:
1969-12-31 17:01:49.354 PreArm: Compass not calibrated

I don’t think you can expect the EKF to work right before you perform the initial copter setup procedures and calibrate the compass.

Also, the “bad” log doesn’t have a GPS. Perhaps the GPS is bad or isn’t connected properly.

My problem is that even after performing all the calibrations, the 2 new drones will always display the Bad EKF error and the GS will be jumping and increasing.

I will try to do all the calibrations again and send the logs.