Pozyx for Non-GPS Navigation

I use ArduCopter v4.0.3 in mission Planner, CU is Holybro pixhawk 4, everything is connected to Arduino UNO R3 and configured as instructed but unfortunately I get an error all the time:

Assertion failed in function: setTxPower
Filename: C:\Users\qwerf\Documents\Arduino\libraries\Pozyx-Arduino-library-master\Pozyx_lib.cpp
Line number: 337

What a mistake I’m making, Please help.

Arduino sketch:
pozyx_drone_mission_planner.zip (3.6 KB)

This message says that your Arduino cannot set RF power level on the pozyx card

Looking at code , you have to change these lines with your tags I’d

Hello , thank you for help

I did change it:

  1. anchors id is 24904 what is 0x6148 hex
  2. anchors id is 34951 what is 0x8887 hex
  3. anchors id is 38491 what is 0x965B hex
  4. anchors id is 47960 what is 0xBB58 hex

I just rewrote the anchor decimal numbers and convert them to hex.
Did I do it well or do I need something different?

Thank you

Looks Good, Unfortunately I dont have these, maybe @rmackay9 could help you.
Have you tried the examples proviided by Pozyx ?

I contacted @ rmackay9 but haven’t received a response yet.
I tried a couple of examples, some work some do not.

I think my tag just transmits its position to the anchors but it should collect information where are the anchors based on his position.

Is it possible to somehow change this on the tag?

On the tag Tx led blinks ,while the Rx not blinking at all.

Just give him a few time @rmackay9 is quite busy :wink:
I read as well that you need the latest firmware, maybe you could check if it is the case

Good Luck

I successfully upgraded the tag (2.2) ,anchors (1.7 ) and gateway software (2020.2) .Unfortunately, I still get an error in the arduino.

Please look at the configuration , I think I set everything up well according to the instructions , but unfortunately there are no instructions/parameters that I need to set on the tag, gateway and anchors themselves.

HI there,

the problem is the assertation for the Tx Power in the Pozyx lib. In the current IndoorLoiter sketch it is set too high. Try reducing it:

#define CONFIG_TX_GAIN 33.0f

That should work.

Best regards

1 Like