Power Problem? APM 2.6 (No red LED)

Hello everyone,

I finally got around to building my Tarot T960 hex with a 3DR APM 2.6 and was calibrating my ESCs without much success.

I was powering APM was from an external BEC through output pin #8 & JP1 installed on the APM.

I reset the power to the board by disconnecting the bec’s servo / power connector and reconnected.

Ever since that power reset I have NO “A” (red) LED activity at all…

I’ve tried disconnecting all accessories, jumpers and tried to power the unit from both BEC power and USB - all other LEDs have some activity - NONE on the “A” (red) led no matter what I do. :astonished:

The boar shows up in wind’s devices as an Arduino Megs 2560 as it usually does but I cannot get a heartbeat in mission planner any longer.

I’ve also checked the fuse and it’s intact…

Running out of ideas now… :cry:

Any help would be greatly appreciated!

If your APM is still under warranty, you might want to open a ticket at help@3drobotics.com
Here is a link to the APM2.5/6 Vcc schematic http://diydrones.com/forum/topics/apm2-5-5v-vcc-schematic
Here is a link to requirements when powering the APM with the J1 link installed: http://copter.ardupilot.com/wiki/common-autopilots/common-apm25-and-26-overview/#power_supply_rails_connected_requirements_jp1_installed
There is zener in series with the thermal fuse and a zener parallel to Vcc. Are you sure that your BEC was supplying less than 5.6vdc?


Thanks for the info & schematic, that will come in handy I’m thinking :slight_smile:

Unfortunately I doubt the APM is still under warranty, I bought the APM in Oct. 13 and for a bunch of reasons only got to building it now… :neutral_face:

Good idea checking the BEC: I did check the BEC and it was outputting 5.22v and also powered the system for a couple dozen cycles and a few hours of operation without an incident before this one - so that wasn’t the issue…

I had reviewed the power requirements page a few times before and after this and all is in line with the requirements.

I ended up calling 3DR and talking with one of their techs, as it turns out the 3.3v regulator seems to be the culprit - It seems the regulator (TI TPS79133DBVT) has a habit of dying. Mine is only outputting 0.5v which is really weird - I’m now trying to figure out if I’m going to replace the board level unit or try an outboard 3.3v source after removing it from the board…

Here’s a video on replacing the VR: youtu.be/Oj-WhDU0bJY

Here’s info on the outboard solution: flight.farbird.com/2014/02/repai … pilot.html

I expect I’ll remove the regulator from the board, supply 3.3v to the pin and see if the APM comes back to life, if it does I’ll order a replacement TI TPS79133DBVT and install it…

I’ll let you know how it works out… :slight_smile: