Power module not reading Volts

Hi, folks. I’ve just put together a new quad based on a 3D Robotics frame and APM 2.6. I got a power module with the APM from eBay.

I have connected the Power Module to the APM port labelled “PM”. I also have a lead from the distribution board that came with the frame going to the + and - of output #1.

The current sensing seems to work, as when I hold the quad down and power up the motors, I see the current rising in the HUD. The voltage always remains at zero though. Shouldn’t I be able to read voltage using this PM?


I ran the copter for a bit at minimum throttle (as low as it’ll go and still not auto-shutdown after 15s) and I get various values show on the HUD, anything from <1V to ~4V. Not sure what it means really…

Is there a reason you set your sensor to “Other” in your power monitoring setup screen? It should normally be set for the 3DR Power Module.

I spotted that after upload the screenshot - I’m pretty certain I’ve had it set correctly previously with the same result - I changed it just now and it’s doing the same thing.

Hi Cylindric,

If you configured as voltage & current, 3dr power module and APM 2.5+ + 3DR Power module it should return you the readings values, from the picture it seems to be returning only the USB power readings. So if you configured it properly then there must be a problem with the hardware. Check the cables are doing good contact.

Here you can find more information about the power module:
copter.ardupilot.com/wiki/common … -with-apm/

Aah good link. I’ll have to pop the case open and check the wiring - I must admit, it’s just how it came from the shop so I’m not sure.