Servers by jDrones

Potential Thrust Loss error

Hi,
Why pixhawk give me Potential Thrust Loss error durring first etap landing with speed >= 2m/s?

when WPNAV_SPEED_DN < 150cm/s then all is ok.

I have the same problem. Arducopter 4.0 firmware
I have done each and everything like compass calibre, radio and ESC calibration many times to get rid off
But no luck than I changed my simonk ESC’s as well as motors , I have 2212 920 kv ready to sky motor but again no luck
Finally after 2days i erase firmware 4.0 in my cheap pixhawk clone and custom install firmware 3.6.9 and everything works fine like a charm

Please post log here!

1 Like

Copter-4.0 includes some additional reporting and improvements to handle motor failures. It’s possible that we could remove the message for quadcopters (that can’t do much about a motor thrust loss as far as I know) but on the other hand it may be an indication of a real problem (like a motor imbalance) so as @Mallikarjun_SE says an onboard log file would be good to see.

1 Like

I’ll try next time when on my desktop, actually I am in government job so occasionally and typically have time for my own hobby
I read in a topic that an hexacopter (may be yours) got crash and it would be saved if flight controller sense it on time or could land as quadcopter so this improvement in copter 4.0 will help in motor failure like situation

I’m study and rebuild firmware for my prototype ( Dron as paraglider drive ) and found this problem when speed down is high :slight_smile:
when drone go down and command is stoping drop, or move up then controller gives full throttle (inside firmware variable) ant if drone still go down after 1s then is raported as Potential Thrust Loss. I changed it from 1s to 2s and now all works perfectly.

line is in crash_check.cpp file

// Code to detect a thrust loss main ArduCopter code
#define THRUST_LOSS_CHECK_TRIGGER_SEC 2 // 2 second descent while level and high throttle indicates thrust loss

1 Like

I’ve been having a terrible time with my quadcopter also running 4.0. I am going back to 3.6.9 if I can figure out how to do it.

I tried using 3.6.9 but my motors will still not spin up either when doing motor tests or after arming in the heads up display. I’ve tried everything I can think of including a different pixhawk 2.4.8 unit. The only thing I haven’t swapped out is the power converstion unit.
I am back to using Mission Planner copter 4.0.2.
I am getting a Battery failsafe message that I have no idea what to do about and have tried 3 different batteries that I know are well charged.

Read this & set Battery failsafe accordingly
https://ardupilot.org/copter/docs/failsafe-battery.html

One thing you can do is, set LOG_DISARMED to 1 in full parameters list, & post a log .So that some experts can take a look.

I had just begun to wonder about the power module as thats the only thing I don’t have a back up of and just ordered a new one but it won’t get here for a week. I can set the LOG_DISARMED to 1 but not sure how to download/post a log. I’m very new to all this and greatly appreciate your assistance. Pleas be patient with me.

This will guide you,
https://ardupilot.org/copter/docs/common-downloading-and-analyzing-data-logs-in-mission-planner.html
upload the log to any cloud storage & post the link here. As I 'm not an expert, somebody will sure help!!

https://www.dropbox.com/sh/mh64cgc4kawapva/AADqE1osQILAdkg8szszFiDUa?dl=0

Link to log files. I only put about 10 logs into the folder since I had nearly a gig of files on the micro SD card. I had taken that card from another Pixhawk that was doing the same kind of thing the one I’m using now was doing but the ones that are dated Feb 15, 2020 are the most recent.

A suggestion. Don’t post a bunch of logs for someone to review. “Only about 10” is about 9 too many. You will get more help if you post 1 or 2 logs with a brief description of the flight they came from. If you don’t recall what log is what delete them, or save them elsewhere if you want, and create new ones from another flight attempt.

1 Like

I wasn’t sure what was appropriate. I’ll edit them down and do as you say. Thank you!

I put one new log file in that dropbox deleted the others. if someone could take a look at it and tell me if it says something about why the motors on my quadcopter won’t run.
Dropbox link to file:


if this doesn’t work or is not the right kind of file, please tell me.

I don’t know how you are powering that craft but you have the low battery FS set for 20.2V and your battery is showing 8V in the log, then it drops to zero at the same time Vcc is below brownout voltage. Usually You can tell what battery voltage is being used form the MOT_BAT_VOLT_MAX parameter but you have that set at zero. All the parameters look like thye are set at default so I’m guessing you didn’t follow the basic tuning guidelines. But anyway solve your power problem 1st.

that gives me some place to start. I started out with a udemy.com course on how to build a quadcopter and as far as I can tell the course does not cover basic tuning guidelines. He may have covered it but I’m completely deaf and the captions on a lot of this stuff aren’t very good.

OK, got it. I would check your power module. What battery are you using (3S, 4S, 6S)? The basic tuning guidelines are here:
https://ardupilot.org/copter/docs/tuning-process-instructions.html

It’s a starting point for a new craft, most likely further tuning will be required. Most have good success with Aututune.

I have several batteries. I started out with 2, 4000 mah 2 cell batteries but was not getting very good flight times, ( I had it flying OK for a while ) Then tried some 3 cell batteries I had from when I used to fly airplanes ( 3S 22500 mAh, 2200 mAh). I was getting lots longer flights with the 3 cell batteries even though their capacity was about half as much. I don’t what I did to my programming after that but have been having problems ever since and probably did foul up the fail safe as I was trying to figure out why my motors were not powering up consistently. Thank you for your help.

Servers by jDrones