Potential Thrust Loss during full throttle climbs

Hi Everyone, I would appreciate some help in determining the cause of this error message and also the inability of my hexacopter to climb at full power for more than a few seconds. Here are the specs of my hex:

Blue Cube H7
Ardupilot 4.0.7
KDE 4213-360 kV motors
T-Motor NS18 x 6 props
Tattu 6S 22A LiPo
Custom 1100 mm carbon fiber airframe

Here is a log from today’s flight. It flies well in Pos Hold and Auto mode as long as I do not apply too much power. Any insight would be most appreciated!

Log File

The thrust loss message is right at the ramp up for this second take off

and you can see current really spikes at the same time, but it doesn’t at the first take off.

So I’m not sure if there’s an overheating issue with motors or ESCs. There’s a bunch of settings for those ESCs too…

So no definitive answer from me, but there’s some other stuff to keep you busy :slight_smile:
These are in conflict and need to fixed:
and also later MOT_THST_HOVER goes up to 0.159
so probably set
but be sure and test them with Mission Planner motor test for reliable start up.

The other issues are a physical yaw bias, CW motors 1, 3 and 6 are working hard to counteract a twisted motor mount in CCW motors 2, 4 or 5.
Frequently motors are reaching their minimum in maintaining stability, so fix the yaw issue, maybe set INS_GYRO_FILTER up to 23 and run autotune again.
Setting up the Harmonic notch filter would help improve the tune too. Let us know if you need help with that.

Thanks, Xfacta! I was reviewing the settings on the KDE ESCs yesterday and I think there is one that I will change back to default. I will also change the MOT_SPIN parameters to the values you recommend and test them on MP with the motor test feature.

Regarding the physical yaw bias, my motor arms are square carbon fiber tubes with carbon fiber motor mount plates fastened directly to them. I will check them for any twisting but is there anything else that might cause this bias?

I will set the INS_GYRO_Filter up to 23 and run another autotune as well. I would also very much like your assistance setting up the harmonic notch filter. Thanks again!

This is my summary of the Harmonic Notch Filter instructions in the doco.
Post a new .bin log here at each phase if you need help reading the FFT, it’s quite easy when you know how.

HNOTCH phase 1

  • hover test >1 minute, check FFT

HNOTCH phase 2
INS_HNTCH_ENABLE,1 <- set this then refresh params to see the rest
INS_HNTCH_REF, hover_thrust
INS_HNTCH_FREQ, peak freq from FFT
INS_HNTCH_BW, peak_freq / 2

  • hover & dynamic test >1 minute, check FFT results

HNOTCH phase 3

  • no extra logging, assumes HNOTCH is working great
1 Like

xfacta Shawn

Thanks for having reported in a simple way the various phases of how to set the filter … one thing is to read the wikiki and the other to learn how to apply it from people who know how to do it physically and who can therefore guide you step by step in activating this filter in the best possible way … especially for us beginners … Which I have not yet understood from how the value of the frequency to be set is obtained … from what you see … from the peaks what are there in the graphs maybe ??? If this is the case, the value we deduce from it seems to me not precise enough … give me indications.

If you have a .bin log from “phase 1” then we can view it and show how the peak is selected, and the correct peak to select.
That probably belongs over in the Harmonic Notch Filter thread rather than in someones Thrust Loss thread.

Xfacta sorry for interupted here …I was asked you help to determine the peak frequency for 28inch quad copter.

I was just estimated it’s 60hz .i want to you to recheck and confirm the peak frequency .
Thank you.

I changed two ESC settings based on a response I received from a software engineer at KDE. He suggested that I disable synchronous rectification and set the acceleration rate to the default (medium-high).

I conducted a short test flight and on a positive note I did not receive the “Potential Thrust Loss” message during a full throttle climb. Unfortunately, I received some other error messages and even one indicating a crash - which did not happen. This was surprising and I have attached the log from today’s test flight:

All KDE Direct ESCs are opto-isolated and do not provide BEC power output for the peripheral equipment and requires 3 to 12V applied to the control lead.

From the user manual: you need to power the servo (esc) rail.