Possible Bug


I have my heli tuned well in stabalilze mode now. Remember, I am running a flybarred helicopter using H1 and the Flybarless setting. I am happy with both pitch and roll rate P=.05 I=.25 D=0 IMAX=500 and FF=.04. The heli feels like a plane with dihedral, when I roll it and let go, it rolls back. it seems very tollerant of high P values, when it wobbles it is not violent.

In a prevous post, sombody mentioned that he had broke landing gear when he switched to Alt_hold or Loiter can’t remember which one. I can reproduce his condition. He also mentioned 10 seconds before loiter or Alt_hold would work.

My normal response on the bench (Heli armed) and the mode changed to Loiter ro Alt-Hold was the swash would drive down to almost full negative pitch. The only difference was Alt_Hold I had cyclic and Loiter I had nothing. So with this resopnse, I was sure if I changed modes, it would end poorly.

So, tonight, I finished my rate tuning, getting dark, so I landed pulled full negative to burn off the rotor speed and switched the Heli in Loiter. I notice somthing different, I had a little cyclic. So I moved the collective to full positive, and the swash traveled slowly to full positive. Now we are getting some where. I tried switching to alt_hold and the same thing, I could move the swash up and down at a slow rate.

Humm, why did it do that.

So, I disarmed and re-armed the Heli, and it was back to its old thing, Loiter and Alt_hold drive the swash full negative. I switched back to stabalize and spooled it up and hovered it for 60 seconds or so, landed, shut down the motor, and loiter and ALT_hold functioned correctly again. This is a scary situation, loiter or ALT_hold is engaged, too early, it will screw itself into the ground.

Is this a leftover from the quad code, I take off on my IrIs most of the time in loiter. Right or wrong, I arm the IrIs, switch into loiter and hit the throttle, it takes some time after the “ARM” before the throttle will respond. (I make sure it has a GPS lock before I arm). The difference is the quad spins the motors on the ARM, the Heli does not.

Is the Pixhawk looking for a PWM signal on the throttle before it enables the “smart modes”

making more progress, I will try alt_hold and Loiter tomorrow after I fly it for a bit.


Into this for two weeks now, sorry for the lengthly posts. Most of this is not obvoius to a Newbee attempting setup on a PX4 control system.

Bruno-1600 called it, a little hard to understand, but I understand him completely now. Before Alt_hold and Loiter will enable after I spool up the heli seems somewhat random and can take a long time to function. I hovered over a minute and it would not work correcty (swash full negative when Loiter selected), the next time it took 20 seconds or so turned the motor off and it worked (swash followed collective stick slowly). Thinking back, I never was able to get correct Loiter and Alt_hold collective movement with the ISN_MPUGK_filter set to zero and 20HZ. Today was the first time I saw correct behavior and the first time I tried 10hz. Thats why I kept asking the same question on what is the proper behavior of loiter/alt_hold because what I saw (full negative) was not going to work out in flight.

Somthing else I did not know, changing the filter you have to tune your rate PID’s again. seems like cutting them in half when you change from 20HZ to 10Hz is pretty close. I am currently runing 10Hz at the PIDs listed in the first post.

I switched the H_RSC_MODE to 0 now. Bruno said in his post that this condition does not occur with the ESC signal bypassed (set to 0). He is correct, I can now test Loiter and Alt_hold on the bench with the system armed. I understand it is possible to fly with the system not armed. I allways check all controls before I fly, so for now, I am going to check my flight modes for correct operation unstead of wondering everytime I hit the loiter switch if the heli is going to go full bore tward the ground.

Now on to Alt_hold and Loiter tuning.

Finished Miniature Aircraft Xcell SE99

9.5 to 1 gear
Actro 32-3
Jeti Mezon 130A ESC+10A BEC set at 5.3V
SAB 690 blades
JR 8311 Servos
Futaba 6208SB reciever
PixHawk PX4 from 3D robotics
kyosho zeal vibration tape under Pixhawk

Bobby, I realized what your problem is with bench testing Alt Hold. Not only does it need to be armed, but you need to set Ch8 high if you’re using RSC_Control 1 or 2. Then, after you arm, and turn on the motor, it will wait for a period of time, controlled by RSC_Runup_Time before the collective becomes active. During this runup time, the swash will be locked to Land_Col_Min. Land_Col_Min should be set to a mild negative pitch, like maybe -2-3 degrees. So the idea is, that while the motor is running up, the heli will be held down on the ground, until the rotor is up to speed. But it won’t be trying to “screw itself into the ground”. Once the runup is complete, it will activate the collective pitch.

Sorry it took me a while to realize what the problem was with your bench testing. It’s hard to remember these nuances while sitting at my desk in the office. :wink: