Pop sound of sparking

Battery 6s 18A , 15c
Fc :pixhawk 4 holybro, with PM06
Esc 60A hobbywing
Motor :320kv
Issue : I upload the firmware of ardupliot into the pixhawk 4 and when I connect battery (xt90 -s) to PDB I can hear pop sound of sparking… But when I upload px4 stack firmware their is no issue… Why like this…? Try many times but same result.

Hope it is clear. If not you can ask me this… I will clear maximum I can.

Are you using the anti spark XT90…if you are its burning out


Hello sir, I try to open that link but due country difference or reason due to that i can’t open.
Here I uploaded a photo.

images - 2021-07-15T062044.895

This one.

The pop sound and spark is definitely hardware related and cant possibly change by using different firmware on the FC. The difference will be the amount of time between connection/disconnection/reconnection and the amount of charge retained in capacitors.
Also it matters how fast you plug in those anti-spark connectors - they have a resistor that is in series that is in play while the connector is only half way plugged. Once the connector is fully plugged together, the resistor is bypassed and only uses normal gold contacts. So plug them together slowly to allow some current to pass through the resistor and charge capacitors somewhat, then push them home all the rest of the way.

EDIT: As Ricky points out, the resistor can fail then you dont have an anti-spark connector

I use these all the time and had a few go pop and burn up.
They work by having a resistor that allows for the circuit to take up a charge slowly so that when you plug them in all the way there is no pop. Like Shawn says, use them slowly.

I tried that too connect slowly , hold 30sec to charge it… After pushing i again heard that voice.
Q) then can you please tell why there no sparking when I upload the px4 stack firmware instead of Ardupliot?

Ok I will try it again. Thanks both of you