Poor performance in Manual Mode - Matek 765WSE


I’m new here. My sincere apologies for being another first timer that can’t get his FC to work. I’m fairly experienced in RC, Inav, Betaflight and thought Ardurover is the next step to conquer.

I’m building an 1.2m autonomous boat, but before testing the waters I bolted everything to a piece of board to make the learning curve easier. Boy, was I wrong. No matter what I do, I can’t steer & throttle in manual mode. The Servo moves jerky and the ESC not at all, or if I change the Servo Output settings, the ESC speeds up but with the wrong stick and the servo does nothing.

I’m thinking the ESC signal and the servo signal are different or interfering or some sorts. Servo_Rate didn’t do much.

I hope somebody can help me. Thank you!

I think I did all the right steps:

  • flashed the 4.3 Ardurover_with_BL.hex as I can’t get the Ardurover.hex to work. No usb connection whatsoever. Weird.
  • calibrate BN880 GPS & compass (although in Manual mode this isn’t used if I read correctly?)
  • calibrate Accel & Level (skipped the Simple Accel Cal.)
  • calibrate Radio - all channels correspond with the bars and move in the right direction
  • programmed a Throttle switch so reverse is done via a switch (TX16s so airplane Throttle)
  • ESC calibration - Normal
  • flight modes set - starts with Manual

This controls Throttle on CH1 and ignores the servo:

This controls the servo in a twitchy way on CH3, ESC does nothing:

The boat made of an uncut tugboat hull:

1 Like

The #numbers in the servo output correspond to the outputs S1 … S12 of the F765-WSE.

For the assignment of the first 4 channels of your transmitter to the inputs of the FC see the RCMAP parameter.

1 Like

Thank you for your help. I checked that, and it corresponds with the channels of my radio and it corresponds with the Radio Calibration Tab.

But it doesn’t make any sense what I’m seeing. In the Failsafe tab, the inputs all of a sudden do not correspond with the outputs. Now all of a sudden my CH3 throttle is showing CH4 output response.

Please post the RCMAP definitions here and the channel assignment of your transmitter.

And the current setting in Servo Output.

You can also upload the parameter file (Config / Full Parameter List / Save to File).

1 Like

Hi Reinhard,

My Radio setup is Mode 2 RTEA
Receiver is CRSF set to SBUS (I’ll deal with CRSF+telemetry later) on Rx6
ESC is on S1, Steering servo is on S3 of the Matek 765 WSE

GPSBoat.param (16.4 KB)

Please see video of the Radio calibration page. What I think is weird is that the channel bars correspond with the sticks, but the name of the bar is not correct.

When I check the outputs on the Fail Safe tab, they are not corresponding whatsoever… I’m stumped.

Again, thank you for your time.

In Mode 2, Throttle and Yaw are on the left, Pitch and Roll are on the right.

Mode 2 is independent of RTEA. RTEA means that you have assigned the first 4 channels in the transmitter:
1 - Rudder (Yaw)
2 - Throttle
3 - Elevator (Pitch)
4 - Aileron (Roll)

Is that really so? The RCMAP definition fits to it, but not your stick operation to the outputs …

Please take a screenshot of the mixer page in the transmitter …

1 Like

For me, this all looks good for now …

You write CRSF and probably mean Crossfire. What does the output map look like? Do the channels all go out 1:1?

Crossfire indeed, set to Sbus. I don’t see anything strange regarding the outputs.

BUT… I tried a Matek 743 WLite… Same problem… When i flash INAV all is working as it should. I need to count to ten before I start doin stupid stuff :frowning:

I meant the outputs in the Crossfire configuration, but if it goes directly with INAV, there will probably be no problem.

Otherwise, I currently have no idea what else it could be. For me, everything looks right so far.

I installed ArduRover once as a test (normally I use only ArduPlane). This works for me right away …

The output that is assigned to Ground Steering on the FC is controlled in my case with the channel to which AIL is assigned.

That your ESC does not work, is probably because you have to set 1000/1000/2000 (Min/Trim/Max) in the Servo Output for Throttle. With 1100 the ESC probably cannot be initialized.

Also, the throttle output is only enabled when the FC is armed. You can also do this manually as a test (Data / Action / Arm/Disarm).

1 Like

THANK YOU. I’m getting somewhere :slight_smile:

I already updated my radio to the latest version of OpenTx, starting from a fresh install hoping for a miracle but… to no avail.

Now, steering works on the correct channel. The only thing that doesn’t work properly… yet is the ESC. Its a reversible ESC and now it goes from 1000-1250-1500, instead of 1000-1500-2000 but I’ll figure that out later. Edit* had to do the esc cal. twice before it got to work.

Still strange that my Radio channels don’t correspond with the labels in Ardurover. I’ll figure it out eventually. For now, I have a starting point.

1 Like

A small update that might be useful to other starters. For less than $3 you can add a mighty handy display that shows status, Sats, Batt and some more to your Matek f765 WSE.

Bought here: https://www.aliexpress.com/item/1005004355547926.html

NFT_DISPLAY_TYPE = 1 to make this work! Do not forget to reboot your FC before the changes work.

1 Like

Update to the question that started this thread:

  • I’ve done a complete update & reset of my Tx16s radio with openTx. This fixed some channel weirdness.
  • When connected to my laptop, the steering was indeed jittery. But when fully controlled via radio (so no usb connected), all is well and smooth. This has something to do with closed loop and open loop feedback if I remember reading somewhere on this site.