Servers by jDrones

Please Help - Directions Problems


(E D) #1

Hi everyone,
I’m a begginner in the quadcopters,
I have a F14893 - K DIY drone, I did every setup level and calibrations, it goes up and down however, it does not go forward, backward, right and left. I’m using FA-i6 transmitter and I tried it with PC simulation, transmitter is working well. How can i solve this problem?


(Shawn) #2

Sounds like RC transmitter calibration is not correct, or the flight controller is not receiving the pitch/roll channels from the receiver.
What receiver are you using? That kit comes with an old APM flight controller, and I think there’s some do’s and dont’s"" to hooking up receivers with them, but I’m not experienced with the APM’s.

In mission planner, under the RC section, do all the green bars move with your transmitter sticks?


(E D) #3

@xfacta thanks for reply,
In Mission Planner, first 6 green bars move with my transmitter sticks, last two don’t move because my reciever have 6 channel.
My receiver is FS-i6 6 channel 2.4 GHZ AFHDS 2A
I don’t know, how can i learn my AMP’s version.

I’m waiting for your response. Thanks for all help.
Best regards.


(Shawn) #4

The sticks should only be 4 channels, and 2 channels left over for switches. I’d say you’ve got some mixing going on there in the transmitter - you’ll need to reset it to all defaults. If it gives gives you any option choose an Acro plane profile or some generic model, dont choose helicopter.
Then rerun the RC calibration and be sure to move the switches too and verify that 4 channels are used for sticks and 2 for switches.


(Shawn) #5

You might just be able to reset the “model” you’ve got selected to get rid of all mixing/expo/other. And maybe the mode as well, mode 2 seems to be the most used, throttle/yaw on the left stick, pitch/roll on the right stick.
Not sure if you’d need to re-bind to the receiver, but you’ll find out quick enough.

Please set up the transmitter/receiver failsafe too, at least set channel 1,2,3,4 to OFF and configure RC failsafe actions in Arducopter


(E D) #6

I think I misrepresented myself. Just like you said, 4 channels fot sticks and 2 channels left over for switches in my transmitter. I did factory reset for my transmitter and it does not affect the situation. Also I played in a pc simulation with transmitter. In that simulation, transmitter works well. I think, I should do something in mission planner.