Please add LIDAR to your section of Hardware

Sorry if this sounds like a repeat. Not sure my message to 3DR is getting through.
Please read below.

Doug Walmsley


I received 2x Lidar Lites this last Tuesday and successfully installed one of them onto my OctoQuad (X8) with Pixhawk as my FC. I would like to start a dialog as I have found issues with Pixhawk and Lidar Lite.

See!topic … OjvyywFyWg


Plus 1

Hello Doug,

I recently received a Lidar Lite as well but have been experiencing difficulties when trying to mount in on my Quad-X. I have connected the sensor to the pixhawk using both methods, I2C and PWM, but have not managed to do this successfully. I have followed the instructions mentioned in the wiki but have not managed to get a reading in Mission Planner’s Status tab.

I was wondering how did you succeed in obtaining data from the Lidar? Did you do any additional steps or am I simply missing something?

Juanjo Campuzano

Has anyone tried the Hardware Fix from PulsedLight3D ?

JoeBob, I have not tried that solution yet.

As of now, I have connected the Lidar to an Arduino and succesfully read distances between 200-3500 cm, using the code provided by Pulsed Light. With the Pixhawk, it’s completely different as I can’t get any readings.

Hi Doug. If your having problems with the Pixhawk and the LIDAR Lite system feel free to detail the issues here and we will help where we can.

Thanks, Grant.

[quote=“gmorph”]Hi Doug. If your having problems with the Pixhawk and the LIDAR Lite system feel free to detail the issues here and we will help where we can.

Thanks, Grant.[/quote]
Hi gmorph,

I am the one who is currently having difficulties with Pixhawk and LIDAR Lite; I don’t believe Doug is having this issue.

I have a quadcopter and I have tried to install the LIDAR Lite system without success. Initially I tried to to so by using PWM signals as specified in the wiki; I did the following connections:

[ul][li]Lidar J1 Pin1 -> 5V servo rail [/li]
[li]Lidar J1 Pin2 -> Pin 55 in above diagram[/li]
[li]Lidar J1 Pin3 -> Pin 54 in above diagram[/li]
[li]Lidar J1 Pin6 -> GND on servo rail[/li][/ul]

After making these, connecting a 470-Ohm resistor between Lidar J1 Pins 3 and 6, and powering the system with 5V from a BEC, I connected the Pixhawk to Mission Planner, and in the Full Parameter List made the necessary adjustments to have the specified values:

[ul][li]RNGFND_TYPE = 5[/li]
[li]RNGFND_STOP_PIN = 55[/li]
[li]BRD_PWM_COUNT = 4[/li]
[li]RNGFND_SCALING = 1[/li]
[li]RNGFND_OFFSET = 0[/li]
[li]RNGFND_MAX_CM = 4000[/li][/ul]

Once I went to the status tab, the sonar values kept reporting 0, as shown in the attached image.

Later I changed the wiring to use the I2C interface, following the diagram. I also changed the parameter RNGFND_TYPE to 4, as specified in the list of Arducopter Parameters. The readings kept being zeros.

I believe I have done exactly as the wiki instructs but have not been able to get readings, and this is why I’m sharing my experience. Maybe someone has been through something similar or has identified a different solution.

Thanks for your help!
Juanjo Campuzano

Hi, similar problem - lidar lite on I2C and fix value on flight stats (0.14m, 0 volt) not changing. Set ground station as wiki for pixhawk

I am also having similar problems with my pulsed light unit.

I have used the same settings as Juanjo Campuzano and i also only get a reading of 0 in mission planner;


However, i have tried this;

And i get sensible readings via the serial monitor window in the arduino client (i.e numbers get bigger as i point the LIDAR at things with are further away).

I do not know why i am getting nothing in mission planner and i can’t see what i’ve done wrong.

The LIDAR unit definitely works using my little arduino device and pulsed lites’s arduino software so i am guessing the problem is with the settings on the pixhawk or the way it’s wired up to the pixhawk.

If anyone has any suggestions i’m all ears!

Got Lidar working on my bench. Used the new Wiki info and set it via PWM.

Felix posted a YouTube video that helped. …

Minimum range = 20cm, Max = 4000 cm.

Now to get it flying.

I wish i could get mine working :frowning:

Latest update;

I have created a little breakout board for the pulsed lite sensor since last week so that i can wire the sensor into the pixhawk via the PWM interface whilst simultaneously measuring the voltage across the resistor between the mode pin and the ground.

I have the 5 volts and ground wired up to a BEC, All other Grounds wired up to the same ground, the PWR En pin is wired to digital input pin 55 on the pixhawk, the Mode pin is wired to digital input pin 54 on the pixhawk. The mode pin is also wired to a 500 ohm resistor which is wired to the same ground.

On the pixhawk I have enabled;


As per the wiki; … lidarlite/

I have the Lidar Lite pointing straight up towards the ceiling. The surface is a matt finish - it’s non reflective.

I can read the voltage across the 500 ohm resistor with my volt meter and i can see it changing in a sensible way as i bring things closer to and further away from the LIDAR sensor. The results seem very repeatable.

I cannot get the pixhawk to detect any results from the LIDAR. I only ever see sonar range and sonar voltage as 0 via mission planner.

At this point i am a bit stuck. The LIDAR seems to be working fine, at least as far as my voltage meter is concerned. My Pixhawk setup looks identical to other people’s who claim to have the system working. I have tried 2 different Pixhawks.

Could i use a PWM conditioner to turn the PWM voltage into a smoothed analogue voltage with a capacitor to get a reading via one of the analogue input ports? It doesn’t seem like a sensible way to do things when i should be able to get PWM working or (if i had the latest hardware) i2c instead. I would guess a digital interface would give better readings than analogue but i don’t really know for sure.

Any other suggestions before i send the LIDAR back?

For the benefit of anyone else reading this; i now know why the LIDAR was not working on the PWM interface.

It only works if you are running the beta version 3.3 of arducopter. I was trying using the latest stable release which is 3.2 at the moment.

So double check what version of the software you are running if you can’t get it working.

Even though a lot of the youtube videos claim to show it working on 3.2 it does not appear to, at least not for me.