Plane is not going to waypoint, drawing circles instead

I’m using Pixhawk 1 (has numbers 2.4.8 on its housing) and trying to perform a autonomous mission.
After setting waypoints and manual takeoff, I set the switch to the AUTO mode and expect the plane will go to the first waypoint. But instead, it starts drawing circles (or the “8” shape) right around where the home location set.

While I don’t know much about this, here are some information that I think might be relevant:

  • There is a waypoint near the home location: “Tracker Home”
  • During the flight, on mission planner the alert “compass variance” showed up. (I was calibrated the compass right before the flight)
  • Using Ublox Neo M8N GPS with compass, plugged in to the sockets “GPS” and “I2C”.

I believe there is no magnetic interferance around, I’m flying at a empty field, and gps module is away form the motor.

How can I solve this?


Do you have an Antenna Tracker?

1 Like

Do you have a non-zero WP_MAX_RADIUS?
“Using a non-zero value is only recommended when it is critical that the aircraft does approach within the given radius, and should loop around until it has done so. This can cause the aircraft to loop forever if its turn radius is greater than the maximum radius set.”


I did not intentionally set any antenna tracker, and only using digi xbee as telemetry module on my PC at ground. I will check if its enabled or not on my next flight. And do you know how to disable that? I checked the ardupilot website and see only the enabling settings.


Yes its set to a non-zero value.

I think @trevellyan has the right answer.

1 Like