Plane 4.0 release

I can confirm @palm369’s issue… I am using a cube orange and a mini carrier board. Continuous reboots. Logs here:!AunBK4rE1ZDCgcgjiW712ywQCz52uw?e=0mcXDc

Thanks Nathan! I was just preparing for testing myself again.

I can also confirm that this is not an issue with 4.0.0 Beta 2, and this is the same issue both Cube Blue(black) and Cube Orange. Kind of frustrating that the stable release as a bug when the last beta I tried didn’t… Guess I should have done beta 3 and 4.


I was able to find new documentation in WIKI about this subjects:

• in-flight compass calibration:

• added AFS_MAX_RANGE for limiting vehicle range:

I am very interested in this feature, but I wasn’t able to find documentation about this: “support for additional RC input on any UART”

Could anyone? Regards.-

Anyone know how we’d go about setting up the WS2812B LEDs on an F405 Wing?

see this thread WS2812B (NeoPixel) Integration

So basically it doesn’t work right now?

1 Like

Control from scripting works, but rgb led mode seems to be broken.

Does scripting work on the F405-Wing? Didn’t think it had enough flash. Thinking about an F765 for that very reason. Thinking LUA so maybe talking about something different.

Not at the moment, but I am considering making it possible by having a build that includes only one of EKF2/EKF3, to save enough flash for scripting

Hello, I am configuring a Matek 765 with arduplane 4.0.0 and everything works fine, rssi, airspeed, compass etc … but channels 5 and 6 do not work. I have re-signed the firmware, configured three times and the servos I connect do not work.

I have checked welds and everything seems fine.

Does anyone know if there is any firmware problem? I have read more people with problems in those servo outputs.

Greetings and I hope you can help me.

I just found that it is a firmware problem and that they are solving it. Is that so? My English is bad, I’m sorry.

I guess so, but I think I saw something someday that they already have one of the beta versions of 4.0 with that solved, I haven’t tried it yet… I prefer to live with it for now and wait for the version 4.1 stable, I am pretty sure that this issue will come solved


That was my fault, and I will fix this in plane 4.0.1. If you’d like to test master (download ‘latest’ firmware from you could test the fix now
Cheers, Tridge

You mean this firmware?

Yes, that’s the one.

Can you tell when this next stable version will be available?

I expect to do a beta in a couple of days

Ok, so, for a stable version will be like a week or 2 more depending on the beta results?


Great work on releasing such a big update.
I’m keen to try it but have a quick question.
Can you tell me if there are any changes to the Batt2 configuration. I can’t calibrate current under the previous version as the drop downs are different to Batt1 and don’t allow it?
The other thing I wanted to check was in post #30 you said regarding parameter conversion,
“So load 3.9.11, load your old parameters, then load 4.0.0beta2 and during boot it will automatically convert your parameters.”
I am currently running a previous version (3.9.10). If I just load 4.0.0 does this definitely just convert the parameters automatically? (this is how I’m reading it). I assume that the “bad idea” would be to load 4.0.0 first and THEN load the old parameters from 3.9.10?