Plane 3.9.1 reversed elevator behaviour

SOLVED: Problem with the plane not with the software


I had reversed elevator behaviour after deep stall landing recovery. Please find my log here: – deleted –
That was first flight with this plane after upgrading it from 3.8.4 to 3.9.1. During that flight, it was a 3rd time when I initiated deep stall landing and tried to recover, but this time I couldn’t recover from it as in place of levelling the elevator, autopilot moved it to a position “nose down” and keep holding it like that until the plane crashed.
I did the same thing many times with 3.8.4 and it always worked good, but not this time. Any ideas what happen?



Some more info with charts.

One of the stalls which I have done during the same flight (successful one):

  1. When deep stall starts elevator goes up to 800 PWM and makes a stall.
  2. Later when the plane dropped to around 90m altitude I have switched to FBWA and recovered the plane from the deep stall. Elevator leveled automatically without my intervention.

Another deep stall after which I wasn’t able to recover the plane as the elevator went down telling to the plane “nose down”:

  1. Deep stall starts
  2. Again, when the plane drops to 90m altitude I switch to FBWA
  3. The elevator goes down telling to the plane “go down”. But it should level in place of it.
  4. The plane goes down.
  5. When it dropped to 30m attitude I command with elevator stick “go up”, but elevator goes down even more. Although I’m not sure if it’s related to my actions.

Very strange, why in FBWA the plane kept nose down when the plane was already pitching down at 45 degrees?

OK, I find out a little bit more. It’s not about reversed elevator nor 3.9.1 I found that elevator was working in reversed order because the roll was over 90 degrees. Don’t know why the plane couldn’t recover but that could be also a problem in the plane.

The question is closed and I’m digging deeper what went wrong :slight_smile: