Servers by jDrones

Pixracer and Tfmini not working


(distiking) #1

I have connected Pixracer 1.0 and tfmini via Telemetry1, it is powered by external 5v 3a power BEC and sharing GND with Pixracer. The settings on arducopter V3.6.5 are:

RNGFND_TYPE 8 (lightware serial)
RNGFND_MIN_CM 30
RNGFND_MAX_CM 600

SERIAL1_BAUD 115
SERIAL1_PROTOCOL 9

I have tried both standard and Pix Mode, on standard mode it says Bad Lidar Health but when I change to Pix Mode the Bad Lidar health message no longer appears but I get sonarrange 0 no matter what I do. I can get this thing work on anything but Pixracer (even omnibus f4 has no problem with arducopter and tfmini). Anyone had similar issues and know how to solve that ?


(ppoirier) #2

I have 2 PixRacer working with TFMINI.
Did you tested with the sensor connected to a FTDI serial to USB connected to a terminal @115kbs to see if you have clear text distance reading?


(distiking) #3

yes, when I connect to serial terminal and set to ascii I can see the distances such format 1.55, 2.66, this looks like pix mode is on. When I switch to standard mode and unplug and plug again I see unreadable trash do it looks like it is sending binary and modes are switching successfully however I can’t get sonarrange in any mode. I have tested this unit with pixfalcon, pixhawk and omnibus f4 v3 and no problems. When I switch to
pix mode the controller stops displaying bad lidar health message so seems like the data is being received but the sonarrange doesn’t update for some reason. Could this be because its traditional helicopter firmware not multirotor ? The other boards I was using was fixed wing and multirotor.


(ppoirier) #4

Well, I think you just answered your question… easy test , save your config (if any) and upload quad firmware


(distiking) #5

sorry for late reply, too busy at weekdays to play with my toys. Today I was trying to upload different arduplane firmware as you suggested to see of this is tradheli issue. When I plugged USB cable to save my settings I noticed bad lidar health message and realized that the battery isn’t connected what caused this as tfmini is powered from BEC. I was tempted to connect the battery so maybe magically the issue fixed itself with time :)…and guess what… magic happened, sonarrange whas showing correct distance. When I unplugged the USB cable and battery and then reconnected the lidar stopped working, so I repeated what I did before and plugged USB and then battery and lidar was working. It looks like the pixracer doesn’t like when tfmini gets power with it simultaneously but needs some time to boot up. Any suggestions what would cause the issue would be appreciated. I don’t want to install external switch.


(ppoirier) #6

hello
looks like a power surge issue, you may try installing a 220uF 10V capacitor on the TFMINI power lines


(distiking) #7

I have just installed the capacitor and it didn’t help. I expected that as the bad lidar health message would appear if this was lidar or communication issue. I was further experimenting and found that this is caused by the telemetry wifi module because I tried to power the pixracer with USB and AC power adapter instead of PC USB and connecting with Mission Planner via wifi telemetry instead of USB and the problem still appear. It looks like this is caused by the other serial and has nothing to do with powering Tfmini later but using different communication method. This must be firmware bug.


(ppoirier) #8

OK I see , you need to update the wifi telemetry module (esp8266) , that can be done using the wifi interface as showned in the WIKI.
http://ardupilot.org/copter/docs/common-esp8266-telemetry.html#changing-the-wifi-ssid-and-password


(distiking) #9

This worked. Lidar is working now. Flashing esp8266 with ardupilot firmware fixes Lidar problem o_O. Thanks a lot for your help. SOLVED