Pixhawk2.1 motors won't run


I’m trying to setup a Pixhawk 2.1 and can not get the motors to turn. they did before I upgraded to 3.5 using the motor test in Mission planner.
They all spin fine when tested using the RPM tester on my charger, but I Cant get them going with motor test or transmitter.


Hi Graham. I as well have a Pixhawk2.1. I haven’t really experienced many issues on my end. I’ve noticed more than anything it’s been mostly on my side and getting acquainted with APM and it’s querks. What firmware are you using? Copter, plane, etc. They all have their little tweaks. A good example on my end is the setting up of a quad plane. Despite endless effort and tests, I realized (and thanks to the APM community) it was more hardware issues on my end. If you can give me some specifics on your end and what your goals are, I can try to provide some direction.

Hello Alexander, thank you for the response.

I am using Copter v3.5 for a quad
BLheli 40a esc’s
2 HERE GNSS GPS units (GPS1 is working but does not track sattelites
Tarrot T-3D III gimbal
Spektrum DSM2 sattelite receiver

In copter firmware, do you have the motors plugged in to the correct output numbers? If I recall it should be outputs 1-4. Sometimes I’ve had to manually calibrate each esc on its own using the rc receiver and throttle channel 3 instead of going thru the mission planner esc calibration. Try that and see if that works. Even in my current quadplane setup I’ve had to individually calibrate my hobby wing x rotors esc’s individually. Soon after it worked like a charm. I would strongly recommend as well to make sure you are using escs specifically made for multi rotors. This was the mistake I made early in my build. Hopefully this helps.

Also did you go thru the setup wizard to calibrate transmitter along with accelerometers and compass? Are you able to arm successfully your quad?

Ok, I’ve got the motors working in "motor test"
I’m using BHheli 40A UBEC ESC on EMAX 3515 650kv motors.
For receiver, I have SPM4648 But I get a “No receiver” warning even though it passes "Radio Calibration"
I also not sure which serial port is GPS2 on the Pixhawk 2.1
I did the setup wizard. I can arm the quad, but the motors just beep and then do not respond to transmitter input. I might buy a 9ch SPK with SRXL. Still looking at Spektrum compatable options.

Definitely sounds like the first place to start is with a transmitter that is able to properly communicate. I’m using a frsky x8r receiver with a tarranis Transmitter…have had no issues.

As for GPS2, regrettably don’t have much experience. I only use the Here+ gps in GPS 1 port on my pixhawk 2.1.

Lastly, check also the flight modes you are in. I’ve noticed the motors arm based on the correct flight mode. For example, in my quadplane, I need to be in a q_stabilize or some type of quadplane flight mode in order to send the proper pwm signal to the esc’s. Just a thought.

I’m using a Spektrum DX9 transmitter. So I think I’m limited to 8 channels. It also will not work with satellites if using a proper receiver.

Check on the ArduPilot documentation for hardware. They always do a good job on mentioning recommended equipment (receivers). I’d say definitely start there.

Thank you again for responding. I’ll read that asap
One things that I am having difficulties with is assigning CH 6 to change altitude hold methods
ie. GPS, Barometric, or sonar (Lidar Lite v3)

I have to do factory reset on one ESC because it’s winding up and down, not instant like the other three motors.

Where can I find ArduPilot documentation for hardware?

Many thanks!

Ahh yes I ran into the same issue while first configuring my esc’s. If what you are referring to as “winding down” is slowing down on its own…it has to do with programming your esc’s to the correct number of lipo cells you are using (common with many esc’s like e-Flite for example). Refer to the esc documentation where it discusses programming based on beeps.

As for Ardupilot hardware documentation: http://ardupilot.org/copter/docs/introduction.html

This is a good place to start. It begins to discuss initial setup and documentation. Many times it provides links to great and recommended resources.

Try also this one which gets into transmitters and receivers:

Thank you again,
I’ll read the documentation and do a factory reset on the problem ESC
I’ll post my results later today.

Thanks again!

Make sure you have set the FRAME CLASS in the parameters.

Copter 3.5-rc1 28-Jan-2017
Changes from 3.4.4

  1. Multicopter firmware consolidated into single binary, users must set FRAME_CLASS parameter (1:Quad, 2:Hexa, 3:Octa, 4:OctaQuad, 5:Y6, 7:Tri)

If your using a QUAD


It just occured to me that I’m less than a few kilometers from two airports. Could this be why it will not arm the motors? Can I turn the airports off for calibration and tests?

I’ve never had an issue on my end.

I’m also getting a “PreArm-Throttle below failsafe” warning.

So I tried to connect a receiver using SRXL, but It will not recognize the receiver. do you need to change any attributes on the Pixhawk for it to work?

Ok, So I splurged on a Taranis X9D transmitter and L9R receiver. Ive seen people get success with that combo.
Is there a setting in the pixhawk to use S.BUS?

Nope.Plug and play.SBUS to RCIN.

Internal Taranis calibration first followed by Pixhawk/Mission Planner radio calibration and you should be good to go.

The Taranis is a fantastic bit of kit for the money.