Servers by jDrones

Pixhawk2.1 GPS2 as only GPS

Hi.

I’d like to use GPS2 as only GPS for Pixhawk2.1.
However, when I connect my GPS module on GPS2 port and run Mission Planner, it seems not work properly.

I can check gpsstatus2, gpshop2, and satcount2 has some values, but HUD says “No GPS”.
In the status field, I can check lat and lon data - which seems to receive GNSS data in somehow.

How can I solve this problem?
Please help me. Thanks in advance.

Set the parameter GPS_AUTOSWITCH to 3
It will force to use GPS2

It only works with master, so make sure you are using that.

Hi friend,
what does it mean: “It only works with master, so make sure you are using that.”?
I’m a problem whit Hacc and Vacc of my Pixhawk 4 whit RTK module on Serial4 port… Hacc and Vacc is calculated only on valors of main GPS (3DR default M8N gps in box whit Pixhawk).
My Arducopter version is 3.6.11 and in my option for GPS_AUTO_SWITCH i only possible valor of 0-1-2 but none of these causes Hacc and Vacc to be calculated based on GPS2 RTK data.

Thank’s to all for help.

@amilcarlucas

Good news, you no longer need to compile the master branch from github repository to use this.
You just need to update to copter 4.0.0-rc1 version, available from mision Planner.
Then the value of 3 will be possible as well.

Very thank’s @amilcarlucas :slight_smile:

Servers by jDrones