Pixhawk won't initialize

I have a new 3DR Pixhawk and am new to the unit as well.
I connected it up, and then flashed the firmware using APM Planner on a Mac. But, the unit will not startup correctly. I keep getting the “Startup Failed” sound when I reboot it. I do have an SD card installed, and I also found a Windows machine and installed APM Planner on that, only to get the same results (at first I suspected a Mac USB driver issue and posted in the Planner forum). It seems to flash correctly, but then will not startup correctly.
I also tried to disconnect everything except power, USB, speaker and the switch and rebooted, but I get the same results.
Any suggestions for what to try or how to diagnose the problem?


Try reseating the micro SD card in its holder and then try booting up.

Thanks, I tried that, with no change. I have taken it out and replaced it a few times.
The card is one that came with it, so I have not put anything on the card, other then to flash it, in place, using APM Planner.

As a last resort, you could try holding the arming switch closed during power up.

I tried that, and got the tones that sound like Close Encounters, and then later got the failed initialize tone again.

I’m having the same problem.

So far I have:

  • Replaced the SD card.
  • Loaded Arducopter, then reloaded Arduplane
  • Tried using APM Planner 2.0 and Mission Planner
  • Depressed the safety switch and rebooted after flashing the firmware (It gets close, goes through the new firmware tones twice, begins the last set of tones and is interrupted by two long tones and a solid red LED)
  • Tried booting with the GPS connected and disconnected
  • Powered through the USB and via the 3DR power module

The crazy thing is that is was working.

I was connecting to APM Planner fine, had used it to configure the switches on my Tx to switch between different flight modes. I setup the channels for the controls. I updated to the V3.3.0 firmware for Arduplane and noticed I could no longer Accel Calibrate. I waited for a few days for the fix for the firmware to come out and now I can no longer boot the Pixhawk.

This had happened previously. I must have tried to reboot the pixhawk 30+ times. I left it and came back to it and it booted up.

I have no idea what to do.

Does the Tx/Rx need to be connected to the Pixhawk for the system to boot?



Thank you, that’s 1 less variable.

Any suggestions on what I might do or what I’m doing wrong?

Thanks in advance,