Pixhawk won't execute RTL comand

Radio Futaba C7. Receiver FrSky TFR4SB. Pixhawk running apm plane 3.0.3

Problem. Pixhawk does not go into RTL when the receiver tells it to because of a loss of TX signal

When I flip ch 7 to low the pixhawk sets it into RTL, as expected, but when my frSkyTFR4SB Sbus receiver goes into failsafe mode and sets ch 7 to low [after loss of TX signal] the pixhawk does NOT go into RTL.??? How can this be??? I can literally watch via telemetry / ground station and while looking at the ‘set up’ ‘radio calibration page’ that ch 7 does goes to low both when I do it or the receiver does it itself via failsafe [ loss of TX signal ] yet the pixhawk seems to only recognize that ch 7 has been switched to low when I do it. i.e. It won’t got into RTL?? I am at a complete loss.

If anybody has any suggestions to try I would really appreciate it. I would really like to get this working as it would be far safer. Thanks

Here’s a Tlog file I think I’m still a little fuzzy on that.

All I did was boot it up then wait for gps lock. Then I manually changed the mode from manual to RTL. Then back to manual. Then I shut off my TX and it should have seen a call to change mode to RTL but as near as I can tell it doesn’t. Yet as I said shows it is brining ch7 to low which is the call for RTL. What a bummer I don’t get it!!!

I had to instal a SBUS to CPPM Converter. Works fine now WITH NO other changes. It should not need one though. Sure wish I knew why. The problem is solved but the reason it needed the converter isn’t. Sure wish somebody had a clue. There is all indication it [ the pixhawk ] is being sent the correct channel / mode switch command to RTL but isn’t doing so.
ebay.com/itm/231237956016?_t … EBIDX%3AIT

Hi govsux,

The Throttle Channel (CH3) is used as Failsafe incase you lose TX signal…

So switching channel 7 is not recognized as failsafe channel…

See setting up Throttle failsafe in MP (Usually the Throttle failsafe is set lower (975 range) as the value you can reach on the transmitter when it is at minimum throttle.

See copter.ardupilot.com/wiki/throttle-failsafe/ for the details.

I guess by adding the SBUS to CPPM Converter, your channel 3 is getting below the 975, and as a result it’s working now…


Hi fpvdrone-EG

sorry for the wordy response.

I didn’t explain myself very well. My original set up was the stock Futaba receiver than only had throttle FS. I could not figure out how to get that to work with a nitro engine plane because in order for the pixhawk to see the failsafe it would first have to see ch 3 go to 900 or whatever it is. But unlike a electric powered craft once you kill the engine it’s done. So it wouldn’t do me much good if it went into RTL 1 second after it killed the engine. So I bought this fysky receiver that has all channel FS. But I confused the issue in my first post because I thought ch 3 wasn’t working and it was a result of the new Sbus receiver when in fact that was simply a set up mistake with my TX.

To set the desired FS with the frsky you simply put the controls on the TX exactly where you want them if it loses TX signal. I my case I have ch 7 for the 3 way mode switch. I switched it to RTL then hit the little button on the frsky receiver to set it’s failsafe settings and its all set. Sweet. Now if it loses TX signal it will flip ch 7 to RTL just as if I am doing it myself. HOWEVER… the thing that is the mystery is I can actually see the frsky flipping ch 7 to RTL [ via the radio calibration page ] but yet the pixhawk does not got into RTL. I have no idea how on earth this could be. It’s seems as though the pixhawk has a glitch in the firmware is my guess. However I have read other posts where it worked fine. Seems like some people have the issue others don’t.

Hi govsux,

Actually you did, I completely overlooked the fact that you are flying a plane (APM Plane v3.03)

So you can completely ignore my previous reply…

Sorry !