PIXHAWK won't engage AUTO mode

Hi all,

I’ll admit to being a complete novice so any help will be great.

We’ve been attempting to hook up a PixHawk in HobbyKing’s Bixler 2. First test flights went well in MANUAL/STABILIZE and FBWA modes, but we had an issue when AUTO mode was selected. We’d loaded on waypoints via Mission Planner, double checked them, and attempted to set the craft to follow them once in the air, however, once AUTO had been selected, the Bixler didn’t gain altitude or head towards its waypoint and required a manual take over to bring it back.

N.B. there’s NO pitot tube on board, although all air speed parameters have been disabled.

Why is the craft not following its designated path once switched into AUTO mode? It seemingly stays in FBWA mode. Have we missed a parameter, perhaps one which requires a pitot tube?

I’ve attempted to attach the two flight logs but both files are too large?


Save the log files on Google drive and point to the location in a new post.

This is a Dropbox link to the two flight logs. 64.bin is the biggest and longest, 67.bin a shorter, second flight. Despite AUTO mode being selected during both the craft didn’t go to any of the selected waypoints.

dropbox.com/sh/v93xx1h8ss00 … uitWa?dl=0

I don’t have access to any tlogs I’m afraid.

Two flight logs in Google Drive below

drive.google.com/folderview?id= … sp=sharing

Some interesting things in your configuration. I only analysed the second flight file.
EKF_GPS_TYPE is set to 1. This would imply you have a range finder installed but I couldn’t see any evidence of that. Did you have one?
Your rudder trim (RC4_TRIM) is set to 1617. This seems a little high.
You have RTL_AUTOLAND set to 2. This means as soon as your plane reaches the RTL point (assuming its gone into RTL) it will begin the autoland process. Is this correct?
FENCE_AUTOENABLE is set to 1. This means after an auto takeoff the geo fence will be auto enabled. I couldn’t find any geofence configured though.
Finally - the cause of your problem is you have AUTO_FBW_STEER enabled. Have a read of this link and you will understand why it didn’t work.
plane.ardupilot.com/wiki/ardupla … _fbw_steer

Thanks, Grant.