Pixhawk unstable @ stabalize - flipping @ position hold


im new with the pixhawk, and im having alot of problems.

in stabalize mode, the quadcopter is very unstable.

for example when i take off, then try to hold it on a stable height.

But it bumps up and down constantly.
Even sometimes when i keep the throttle on same value, and not touching it, it goes down , and then after a few meters it goes up again… all on the same throttle input.

Also i need to correct alot, because it drifts alot aswell

Then loiter mode, it keeps landing (while the led is green) this means everything is connected right ?
i even tried to disable gps failsafe and the other failsafes, but still it lands alot of the time. and if it doesnt land, it is not really doing alot on loiter mode.

Position hold is scary and dangerous!, within a couple of seconds, the quad goes crazy, high throttle, flips and finally crashes.

im trying now for weeks , i read alot and tried alot, without getting progress or improvements.

i was hoping, someone could have a check on my log file if there is something clearly wrong.
i really dont understand the log .

thanks in advance

[attachment=0]2014-12-05 21-29-03.log[/attachment]

What version of the ArduCopter firmware are you using and also what GCS?
You should have really posted in the ArduCopter Forum under the correct firmware version.

oh im sorry, i really didnt know this.

i use mission planner 3.1.15

And i tried several firmware, but all give exactly the same problems.

i tried 3.1.5 , 3.2 also differennt release dates.

and the log file i uploaded i did with firmware 3.3

I am moving your post over to the ArduCopter 3.2 sub forum.

I had a look at your log. I do see that it seems to be going up and down in Stabilize mode when you aren’t really moving the throttle, so that is slightly weird. I’m not sure what that is about yet. It’s possible the problem is simply that you are flying at very low altitude (1-2 meters?) and you’re still in ground effect, which can cause this to happen. It also appears your machine is fairly powerful, which can make it even harder to control.

I do see that your Number of Satellites, and your HDOP are not good. And you have a lot of EKF warnings, possibly caused by this. Are you flying inside? You should not be trying to use GPS modes without HDOP lower than 2.5 at most, <2.0 is best.

Are you flying indoors?

thanks for your reply!

seems you are experienced and understand the logs very well :stuck_out_tongue:
i am indeed flying inside, but i thought i disabled the use of gps for altitude.

also i didnt know the pixhawk uses gps in stabilize mode

And i have assigned ch8 for ekf, and dont remember that i enabled ekf at the flight with provided log

so i will try it outside tommorow.

but there should be a way to make it fly decent stable inside, or am i wrong
changing any settings or something?

GPS is never used for altitude, so I’m not sure what you disabled. However, GPS is still used in some ways, even in Stabilize (it’s complicated). Also, if you don’t have all your settings right, you could still get an RTL even indoors. The best thing to do is to completely unplug the GPS if flying indoors.

I did not check if you were flying in EKF or not, but you will get the EKF warning in any case.

It is possible to fly indoors, but it can be tricky in many cases due to the aerodynamics going on in a closed room. Also, the air conditioning or heating system can cause some weird effects which make flying in Alt Hold dangerous. If the system suddenly turns on, and pressurizes the room (it doesn’t take much) the copter will think it is falling, and will climb. I’m not saying this is what happened, just some warnings.