Pixhawk to PC connection issues


when i’m trying to connect the pixhawk to my pc via usb i get the normal entry sound then a blue blinking of the main led and then a red blinking. well, there are some lists showing the meaning of the colours and blinkings, but, and that’s my problem, it actually worked so far. after i did some stuff it “broke” down. first i did a firmware update with mission planner. then i tried to put my 3dr radio telemetry into telem2 (maybe i shouldnt have done this while the copter was still on power) and after that the problem began. after some trials and fails i pressed the reset buttons…
i have that feeling that i did some mistakes but i don’t have any idea how to fix this…can anyone help please?
I also uploaded a short video sequence of the blinking i get.


Where is the video?

Oh sorry seems like it didn’t upload. Well, but now it worked. seems like the sd-card popped out and i didnt realize it. after i put it in i had to do some calibrations(i guess because i pushed the reset-button) which i did with qgroundcontrol.
but there are still a few more questions…but first things first:
now the pixhawk is blinking blue(main led)…should be the sign for gps searching. can i unable this? because in my project i want to start the copter via my laptop(indoor). so i don’t need gps, because it won’t find anyway…