Servers by jDrones

Pixhawk Tip Over on Take Off & Stability Issue

First time building a drone, just to get that out there at the start.

Drone is built using the following:

  • Tarot 650 frame
  • Hobbywing 40A ESC
  • Tarot 4108 motor
  • Pixhawk 2.4.8 FC
  • 6000mAH 22.2V Battey - 6S
  • Radiomaster Tx16s transmitter
  • FrSKY X8r receiver

The above is built and has worked so far UNTIL I tried my first flight. At the point of take off the drone continually falls to one side. I have also set up a rig where the drone is slightly off the ground and I apply throttle when I do this the drone starts to move in a circular format and eventually goes out of control in a circular motion.

It looks like the drone is not stabilising. The compass is calibrated, the accelerometer is calibrated. All the setup is complete as far as I know.

Like I said I am completely new to this and any advice is greatly appreciated. I don’t have flight logs that I believe are worth reviewing.

Thanks.

Did you perform the Motor Test in Mission Planner to confirm proper motor order and direction?

Hi, and thank you for your reply. I haven’t specifically carried out the motor test but I have followed the Pixhawk wiring diagram and ensured the motors are in the correct sequence, turning the correct way and are connected the the correct ports 1-4 on the pixhawk output

Perform the Motor test (props off) and pay close attention ot the Note on the Test page and follow the link so yoiu understand the order the test is run in.

Post the parameter file also.

Will do, I’ll try this as a first step and come back with results. Thanks for your help.

Hi, So I conducted the test and all works correctly. I was fairly confident this was the case as I paid close attention to the motor direction and sequence. I also calibrated the ESCs and all is ok there. I tried again yesterday in stabilise mode and still the same. Either tipping over on take off or when I hang from the rig I made up, about 1 metre off the ground, the quad just starts flying out of control.

I continually receive a “compass not calibrated” message from ardupilot. THis comes in every 30 seconds. I have calibrated the compass and accelerometer about 50 times. When I calibrate the compass it shows me 3 different compass data bars during calibration but when I calibrate only two bars go green the third one doesn’t log any data. I have all three compasses ticked as in use. I will untick the third today and see if it makes any difference but I believe the quad has two healthy compasses and should fly with only one active (I think).

Again any advice is greatly appreciated as I thought the most difficult part of the build would be to make this work, however that was the easy part and it’s not much use as a drone if it can’t take off…

Thanks in advance for any help.

Post a link to the.bin file flight log of your last flight attempt.

This problem is almost always motor order, prop direction or the props are on upside down. It could also be the orientation of the Flight Controller or the FRAME_CLASS or FRAME_TYPE is wrong for the craft.

From Mission Planners HUD does it react correctly when you pitch/roll the craft by hand?

Will download the flight log and post later.

I disconnected compass 3 that’s not reading during calibration and I no longer get the compass calibration message.

Motor order and direction is correct as I tested like you advised above. Sequence is correct.

Props are definitely on right as I had the reversed at the start. Realised the quad was rooted to the ground instead of trying to take off. :roll_eyes:

FC is situated at top of quad with the gps located right behind both facing forward. Battery is underneath as far from FC as possible.

Pitches and rolls manually and HUD displays correct but I’m not fully sure if I pitch and roll with the transmitter as I haven’t got that far in the air…

FRAME_CLASS & _TYPE Are both set to 1 which indicates this is correct - Quad, X

Update: I’m airborne after a day of trouble shooting…

To be honest I think there was a lot wrong. I didn’t have my flight modes set correctly. Spent a long time going through these and failsafe and tweaking settings.

Biggest mistake is that I thought when the motors were spinning I should have been able to fly in my haste to get in the air.

Big learning curve and I’ve gone from wanting to kick the quad down the field to not being able to wait til tomorrow so I can fly in daylight…

Thank you for your help! I’m sure I’ll be back with some new issue soon…

Servers by jDrones